classification
Title: rfc822.py line 395 strings connection
Type: crash Stage:
Components: Library (Lib) Versions: Python 2.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: erezbibi, jackdied
Priority: normal Keywords:

Created on 2008-05-21 14:44 by erezbibi, last changed 2008-08-01 18:45 by jackdied. This issue is now closed.

Files
File name Uploaded Description Edit
rfc822.py erezbibi, 2008-05-21 14:44 my bug fix
Messages (2)
msg67157 - (view) Author: Erez Bibi (erezbibi) Date: 2008-05-21 14:43
Python 2.5 on Windows
rfc822.py line 395
text = name + ": " + value

if 'value' is not a string python will generate an exception. It might
be due to a broken website, but it is not a reason to crash.

I'm using ClientCookie with a Request object (but I don't know the
faulty URL) 

>>> req = urllib2.Request (url)
>>> page = ClientCookie.urlopen (req)
Traceback (most recent call last):
  ...
  File "build\bdist.win32\egg\ClientCookie\_urllib2_support.py", line
824, in urlopen
    return _opener.open(url, data)
  File "C:\Python25\lib\urllib2.py", line 380, in open
    response = meth(req, response)
  File "build\bdist.win32\egg\ClientCookie\_urllib2_support.py", line
412, in http_response
    headers[hdr] = val
  File "C:\Python25\lib\rfc822.py", line 395, in __setitem__
    text = name + ": " + value
TypeError: cannot concatenate 'str' and 'NoneType' objects

A simple fix is to replace 
text = name + ": " + value
with
text = ("%s: %s" % (name, value))
In rfc822.py line 395
msg70582 - (view) Author: Jack Diederich (jackdied) * (Python committer) Date: 2008-08-01 18:45
This is a bug in the external ClientCookie module (and their website
hasn't been updated since 2006).

Marking closed.
History
Date User Action Args
2008-08-01 18:45:40jackdiedsetstatus: open -> closed
resolution: not a bug
messages: + msg70582
nosy: + jackdied
2008-05-21 14:44:37erezbibicreate