classification
Title: set() comparisons do not play well with others
Type: Stage:
Components: Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: ncoghlan
Priority: normal Keywords:

Created on 2008-05-21 13:19 by ncoghlan, last changed 2008-05-21 13:23 by ncoghlan. This issue is now closed.

Messages (2)
msg67152 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2008-05-21 13:19
The rich compare implementation for set objects raises TypeError
directly instead of returning NotImplemented to allow the other type
involved in the comparison a chance at handling the operation.
msg67153 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2008-05-21 13:23
Eh, never mind, raising the TypeError explicitly is necessary due to the
misbehaviour of the default comparisons in 2.x.

I'll work around the problem in my test case.
History
Date User Action Args
2008-05-21 13:23:44ncoghlansetstatus: open -> closed
resolution: not a bug
messages: + msg67153
2008-05-21 13:19:21ncoghlancreate