classification
Title: __slots__ needs documentation
Type: Stage: resolved
Components: Documentation Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: rhettinger Nosy List: docs@python, eryksun, martin.panter, rhettinger, saumitra1978
Priority: normal Keywords:

Created on 2017-01-19 22:30 by saumitra1978, last changed 2019-08-23 05:38 by rhettinger. This issue is now closed.

Messages (4)
msg285850 - (view) Author: saumitra paul (saumitra1978) Date: 2017-01-19 22:30
As you said..assiging it to you :)
msg285854 - (view) Author: Martin Panter (martin.panter) * (Python committer) Date: 2017-01-19 22:48
Have you seen <https://docs.python.org/2.7/reference/datamodel.html#slots>? There is also <https://docs.python.org/2.7/glossary.html#term-slots>.
msg285856 - (view) Author: saumitra paul (saumitra1978) Date: 2017-01-19 22:54
Python 2.7.10 (default, Oct 23 2015, 19:19:21)

[GCC 4.2.1 Compatible Apple LLVM 7.0.0 (clang-700.0.59.5)] on darwin

Type "help", "copyright", "credits" or "license" for more information.

>>> help(__slots__)

Traceback (most recent call last):

  File "<stdin>", line 1, in <module>

NameError: name '__slots__' is not defined

>>> help('__slots__')

no Python documentation found for '__slots__'

>>>

On Thu, Jan 19, 2017 at 2:48 PM, Martin Panter <report@bugs.python.org>
wrote:

>
> Martin Panter added the comment:
>
> Have you seen <https://docs.python.org/2.7/reference/datamodel.html#slots>?
> There is also <https://docs.python.org/2.7/glossary.html#term-slots>.
>
> ----------
> assignee:  -> docs@python
> components: +Documentation
> nosy: +docs@python, martin.panter
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <http://bugs.python.org/issue29330>
> _______________________________________
>
msg285860 - (view) Author: Eryk Sun (eryksun) * (Python triager) Date: 2017-01-19 23:31
Are you suggesting that the Helper class in Lib/pydoc.py should index [sub-]topics by special names such as "__slots__"? Currently you can see the __slots__ documentation via the topics "ATTRIBUTEMETHODS" and "SPECIALMETHODS". The list of topics can be printed via help('topics'). Also when you exit out of help('__') it refers you to the SPECIALMETHODS topic.
History
Date User Action Args
2019-08-23 05:38:17rhettingersetstatus: open -> closed
resolution: not a bug
stage: resolved
2017-01-19 23:45:11rhettingersetassignee: docs@python -> rhettinger
2017-01-19 23:31:25eryksunsetnosy: + eryksun
messages: + msg285860
2017-01-19 22:54:14saumitra1978setmessages: + msg285856
2017-01-19 22:48:05martin.pantersetnosy: + docs@python, martin.panter
messages: + msg285854

assignee: docs@python
components: + Documentation
2017-01-19 22:30:40saumitra1978create