classification
Title: sqlite3 OperationalError on changing into WAL transaction mode
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: execute("begin immediate") throwing OperationalError
View: 28518
Assigned To: Nosy List: berker.peksag, palaviv, yadayada
Priority: normal Keywords:

Created on 2017-01-10 18:19 by yadayada, last changed 2017-01-23 22:31 by palaviv. This issue is now closed.

Messages (3)
msg285141 - (view) Author: yadayada (yadayada) Date: 2017-01-10 18:19
Running

sqlite3.connect('foo.db').execute("PRAGMA journal_mode = WAL")

will throw

sqlite3.OperationalError: cannot change into wal mode from within a transaction

on Python 3.6.0, but not with older versions.
msg285142 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2017-01-10 18:33
Thanks for the report. This is a duplicate of issue 28518.
msg286123 - (view) Author: Aviv Palivoda (palaviv) * Date: 2017-01-23 22:31
There is also a issue with the docs here. Look at issue 29121.
History
Date User Action Args
2017-01-23 22:31:00palavivsetnosy: + palaviv
messages: + msg286123
2017-01-10 18:33:37berker.peksagsetstatus: open -> closed

superseder: execute("begin immediate") throwing OperationalError
nosy: + berker.peksag
components: + Library (Lib)

messages: + msg285142
type: behavior
resolution: duplicate
stage: resolved
2017-01-10 18:19:26yadayadacreate