classification
Title: OS related file operations (copy, move, delete, rename...) should be placed into one module
Type: enhancement Stage: resolved
Components: Library (Lib) Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: georgefischhof, vstinner
Priority: normal Keywords:

Created on 2017-01-10 14:36 by georgefischhof, last changed 2017-01-10 15:05 by eryksun. This issue is now closed.

Messages (3)
msg285115 - (view) Author: George Fischhof (georgefischhof) Date: 2017-01-10 14:36
Hi There,

OS related file operations (copy, move, delete, rename...) should be placed into one module...
As it quite confusing that they are in two moduls (os and shutil). 

I have read that one is higher level than other, but actually to use them I have to think which function can be found in which module. 

It is confuse for beginners, and makes the usage more complex instead of make it more simple (as Zen of Python says ;-) )

An alias could good, not to cause incompatibility.

Best regards,
George
msg285116 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-01-10 14:40
You can design your own "oshutil" module which combines both modules.

They are technical reasons to have two separated modules.
msg285120 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-01-10 14:50
As Jim Fasarakis-Hilliard wrote in msg285117, the *bug* tracker is not the best place to propose changes, so I close this issue.
History
Date User Action Args
2017-01-10 15:05:25eryksunsetstage: resolved
2017-01-10 14:50:54vstinnersetstatus: open -> closed
resolution: not a bug
messages: + msg285120
2017-01-10 14:40:13vstinnersetnosy: + vstinner
messages: + msg285116
2017-01-10 14:36:47georgefischhofcreate