classification
Title: Logger should ignore propagate property for disabled handlers.
Type: Stage: resolved
Components: Library (Lib) Versions: Python 2.7
process
Status: closed Resolution:
Dependencies: Superseder:
Assigned To: Nosy List: Oleg Serov, mariocj89, xtreak
Priority: normal Keywords:

Created on 2017-01-03 17:49 by Oleg Serov, last changed 2019-05-30 22:00 by mariocj89. This issue is now closed.

Messages (6)
msg284583 - (view) Author: Oleg Serov (Oleg Serov) Date: 2017-01-03 17:49
Looks like if I have a logger handler with propagate = False and it is disabled, the "propagate" is still in affect.

I am considering this is a bug, because:
1. I have some random logging configuration with some logging handlers that have "propagate = True"
2. I am setting a new logging configuration by using logging.config.dictConfig with "disable_existing_loggers = True"
3. After that I still "feel" the effect of old config, because some log messages do not reach my new loggers.

What I am doing wrong? Or this is a bug? A bug in documentation?
msg284584 - (view) Author: Oleg Serov (Oleg Serov) Date: 2017-01-03 17:52
> 1. I have some random logging configuration with some logging handlers that have "propagate = True"
Read as: 1. I have some random logging configuration with some logging handlers that have "propagate = False"
msg326103 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python triager) Date: 2018-09-22 17:56
Can you please attach a script that has a relevant sample logging configuration along with the output you are expecting?

Thanks
msg327097 - (view) Author: Oleg Serov (Oleg Serov) Date: 2018-10-05 02:30
I tried and failed to reproduce. If it changes, I'll update it.
msg343674 - (view) Author: Mario Corchero (mariocj89) * (Python triager) Date: 2019-05-27 19:16
Note that "handlers" cannot be disabled. This applies only to loggers.

Also, the following code shows that disabling the logger does indeed prevents all logs in emitted by that logger from appearing:

```
import logging

parent_handler = logging.StreamHandler()
child_handler = logging.StreamHandler()

parent_logger = logging.getLogger('parent')
child_logger = logging.getLogger('parent.child')

parent_logger.addHandler(parent_handler)
child_logger.addHandler(child_handler)

child_logger.disabled = True

child_logger.error("wops")
```

Trying to guess what happened, it might be that there was a child of the disabled logged and you saw the log trace expecting it was the child, example:

```
import logging

parent_handler = logging.StreamHandler()
child_handler = logging.StreamHandler()

parent_logger = logging.getLogger('parent')
child_logger = logging.getLogger('parent.child')
grandchild_logger = logging.getLogger('parent.child.grandchild')

parent_logger.addHandler(parent_handler)
child_logger.addHandler(child_handler)

child_logger.disabled = True

grandchild_logger.error("wops")
```

Note that disable does not affect how handlers across loggers are called. It only disables the logger and therefore prevents from emitting logs that are emitted directly through the disabled logger.

Might that be the case? Are you OK with closing this issue if so?
msg344006 - (view) Author: Mario Corchero (mariocj89) * (Python triager) Date: 2019-05-30 22:00
Closing as unable to reproduce. Please comment if you can reproduce the issue and we can have a further look.
History
Date User Action Args
2019-05-30 22:00:24mariocj89setstatus: open -> closed

messages: + msg344006
stage: resolved
2019-05-27 19:16:54mariocj89setnosy: + mariocj89
messages: + msg343674
2018-10-05 02:30:41Oleg Serovsetmessages: + msg327097
2018-09-22 17:56:44xtreaksetnosy: + xtreak
messages: + msg326103
2017-01-03 17:52:07Oleg Serovsetmessages: + msg284584
2017-01-03 17:49:34Oleg Serovcreate