classification
Title: get-pip.py fails with Python 3.6 embed Windows
Type: behavior Stage: resolved
Components: Versions: Python 3.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Szabolcs Dombi, ammar2
Priority: normal Keywords:

Created on 2016-12-29 16:52 by Szabolcs Dombi, last changed 2016-12-29 17:06 by ammar2. This issue is now closed.

Messages (2)
msg284279 - (view) Author: Szabolcs Dombi (Szabolcs Dombi) Date: 2016-12-29 16:52
Downloaded python 3.6 embedable zip file (windows 32 bit)

Downloaded get-pip.py from the following URL:
https://pip.pypa.io/en/stable/installing/

This is the traceback:

Traceback (most recent call last):
  File "get-pip.py", line 20061, in <module>
    main()
  File "get-pip.py", line 194, in main
    bootstrap(tmpdir=tmpdir)
  File "get-pip.py", line 82, in bootstrap
    import pip
  File "<frozen importlib._bootstrap>", line 961, in _find_and_load
  File "<frozen importlib._bootstrap>", line 950, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 646, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 616, in _load_backward_compatible
  File "C:\Users\User\AppData\Local\Temp\tmpinoq60hn\pip.zip\pip\__init__.py", line 26, in <module>
  File "<frozen importlib._bootstrap>", line 961, in _find_and_load
  File "<frozen importlib._bootstrap>", line 950, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 646, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 616, in _load_backward_compatible
  File "C:\Users\User\AppData\Local\Temp\tmpinoq60hn\pip.zip\pip\utils\__init__.py", line 23, in <module>
  File "<frozen importlib._bootstrap>", line 961, in _find_and_load
  File "<frozen importlib._bootstrap>", line 950, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 646, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 616, in _load_backward_compatible
  File "C:\Users\User\AppData\Local\Temp\tmpinoq60hn\pip.zip\pip\locations.py", line 88, in <module>
  File "ntpath.py", line 75, in join
TypeError: expected str, bytes or os.PathLike object, not NoneType
msg284282 - (view) Author: Ammar Askar (ammar2) * (Python committer) Date: 2016-12-29 17:06
Please post this issue on pypa's get-pip issue tracker https://github.com/pypa/get-pip
History
Date User Action Args
2016-12-29 17:06:25ammar2setstatus: open -> closed

nosy: + ammar2
messages: + msg284282

resolution: not a bug
stage: resolved
2016-12-29 16:52:42Szabolcs Dombicreate