classification
Title: Changing the installation location still adds AppData filepaths that do not exist to the path variable on Windows 10
Type: behavior Stage: resolved
Components: Installation, Windows Versions: Python 3.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: steve.dower Nosy List: Dazc, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2016-12-24 03:13 by Dazc, last changed 2016-12-28 23:22 by steve.dower. This issue is now closed.

Messages (4)
msg283916 - (view) Author: Daz (Dazc) Date: 2016-12-24 03:13
New to python issue tracking; prone to ignorance.

I'm on Windows 10. I noticed after checking to add Python to my path variable and then changing the location from AppData's directory that after the installation, the filepaths associated with AppData were added to the path variable. The new path and any would-be associated filepaths were not added to the path variable.

Thanks in advance if you can at least let me know if this is typical or a problem.
msg283917 - (view) Author: Daz (Dazc) Date: 2016-12-24 03:18
New to python issue tracking; prone to ignorance.

I'm on Windows 10. I noticed after checking to add Python to my path variable and then changing the location from AppData's directory that after the installation, the filepaths associated with AppData were added to the path variable.

Thanks in advance if you can at least let me know if this is typical or a problem.
msg283922 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2016-12-24 05:28
You should have a set of log files in your %TEMP% directory. Could you zip them up and attach to this issue? That should show whether the installer got confused about something.

Note that if you install the launcher but not for all users (the other check box on the first page) you can't actually reconfigure where it installs to, and it will be put on PATH, so you may be seeing that.
msg283974 - (view) Author: Daz (Dazc) Date: 2016-12-24 21:34
You're right. It was the launcher I was viewing. On the first page, I
unchecked installing the launcher for all users. Thanks for pointing out
that distinction.

Happy holidays.

On Dec 24, 2016 12:28 AM, "Steve Dower" <report@bugs.python.org> wrote:

>
> Steve Dower added the comment:
>
> You should have a set of log files in your %TEMP% directory. Could you zip
> them up and attach to this issue? That should show whether the installer
> got confused about something.
>
> Note that if you install the launcher but not for all users (the other
> check box on the first page) you can't actually reconfigure where it
> installs to, and it will be put on PATH, so you may be seeing that.
>
> ----------
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <http://bugs.python.org/issue29060>
> _______________________________________
>
History
Date User Action Args
2016-12-28 23:22:46steve.dowersetstatus: open -> closed
resolution: not a bug
stage: resolved
2016-12-24 21:34:18Dazcsetmessages: + msg283974
2016-12-24 05:28:40steve.dowersetmessages: + msg283922
2016-12-24 03:52:19zach.waresetassignee: steve.dower

components: + Windows
nosy: + paul.moore, tim.golden, zach.ware, steve.dower
2016-12-24 03:18:14Dazcsetmessages: + msg283917
2016-12-24 03:13:53Dazccreate