classification
Title: Coverage related documentation missing
Type: Stage:
Components: Documentation Versions: Python 3.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: Jim Fasarakis-Hilliard, docs@python, patriki
Priority: normal Keywords:

Created on 2016-12-22 10:44 by patriki, last changed 2016-12-22 11:56 by patriki. This issue is now closed.

Messages (4)
msg283824 - (view) Author: Patrik Iselind (patriki) * Date: 2016-12-22 10:44
Is it possible to do coverage -j8 or similar? Cannot find any documentation on this. Coverage takes so long on the tests...

I checked https://docs.python.org/devguide/coverage.html
msg283826 - (view) Author: Jim Fasarakis-Hilliard (Jim Fasarakis-Hilliard) * Date: 2016-12-22 11:48
The ``-j`` arguments isn't present for coverage from what I know.

What you can do is build coverage's C extension. That results in a pretty significant change in overall execution time. 

For information about coverage.py you should also look in the docs for it; you can forward any questions about its usage from there (see: http://coverage.readthedocs.io/en/coverage-4.2/#getting-help)
msg283827 - (view) Author: Jim Fasarakis-Hilliard (Jim Fasarakis-Hilliard) * Date: 2016-12-22 11:50
I suggest this issue be closed as it isn't really an omission, I don't think we should expect the devguide to document *all* of coverage's options. That's what its dedicated docs are for.
msg283829 - (view) Author: Patrik Iselind (patriki) * Date: 2016-12-22 11:56
Agree
History
Date User Action Args
2016-12-22 11:56:44patrikisetstatus: open -> closed
resolution: not a bug
messages: + msg283829
2016-12-22 11:50:43Jim Fasarakis-Hilliardsetmessages: + msg283827
2016-12-22 11:48:50Jim Fasarakis-Hilliardsetnosy: + Jim Fasarakis-Hilliard
messages: + msg283826
2016-12-22 10:44:26patrikicreate