classification
Title: Python 2.7.13 prints version header and exits immediately on Windows 10 x64
Type: Stage: resolved
Components: Windows Versions: Python 2.7
process
Status: closed Resolution: third party
Dependencies: Superseder:
Assigned To: Nosy List: abkhd, eryksun, paul.moore, ruediger.jungbeck@rsj.de, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2016-12-21 19:00 by abkhd, last changed 2016-12-28 23:46 by steve.dower. This issue is now closed.

Files
File name Uploaded Description Edit
python-v.txt abkhd, 2016-12-28 16:13
Messages (11)
msg283773 - (view) Author: A.B., Khalid (abkhd) Date: 2016-12-21 19:00
I updated my Python 2.7.12 to 2.7.13 on Windows 10 x64. When I run it in Windows command prompt shell, Python prints the version header and then exits immediately. Like so:

"""
E:\Users\thisuser>python
Python 2.7.13 (v2.7.13:a06454b1afa1, Dec 17 2016, 20:53:40) [MSC v.1500 64 bit (AMD64)] on win32
Type "help", "copyright", "credits" or "license" for more information.

E:\Users\thisuser>
"""

This did not happen before.

The same happens when Python is run from a powershell. I have no problems running ipython or jupyter notebook, however. And Python does the right thing when run under MSYS2, like so:

"""
$ python -i
Python 2.7.13 (v2.7.13:a06454b1afa1, Dec 17 2016, 20:53:40) [MSC v.1500 64 bit (AMD64)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>>
"""

Could this be an encoding problem? Because MSYS2 is fairly new and I think it might be more friendly to the encoding issues related to Windows shell programming.
msg284159 - (view) Author: RĂ¼diger Jungbeck (ruediger.jungbeck@rsj.de) Date: 2016-12-28 07:41
I have the same problem (on 2 different systems) with the win32 version in Windows 10.

The problem seems to go away when I start python -S so it has something to do with site.py
msg284162 - (view) Author: Eryk Sun (eryksun) * (Python triager) Date: 2016-12-28 08:15
In the cmd shell, run `where python` to confirm that "python" runs 2.7 python.exe, and not a python.bat or python.lnk file. Also, check whether stdin is an interactive terminal by running `python -c "import sys; print sys.stdin.isatty()"`.
msg284166 - (view) Author: A.B., Khalid (abkhd) Date: 2016-12-28 08:30
Running "where python" shows that the updated python (the one with the bug mentioned above) is the one being run.

Running python -c "import sys; print sys.stdin.isatty()" prints out "True".
msg284177 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2016-12-28 15:49
Running "python -v" might show what the last thing it tried to do before exiting was.
msg284180 - (view) Author: A.B., Khalid (abkhd) Date: 2016-12-28 16:13
I enclose the output of "python -v". Where Python exits is of course indicated by the end of the file. However, there is no obvious error that is printed out.

Also it might be worthwhile to note that I cleared all compiled files left over from the previous Python (2.7.12) so as to make sure none of them was the cause of the problem. That unfortunately did not affect the buggy behavior.
msg284182 - (view) Author: Tim Golden (tim.golden) * (Python committer) Date: 2016-12-28 16:48
Do you have any Python environment variables set?

If you're not sure, try at a command prompt:

SET PY
msg284183 - (view) Author: A.B., Khalid (abkhd) Date: 2016-12-28 16:59
Output of SET PY is as follows:

E:\>SET PY
PYSDL2_DLL_PATH=E:\Python27\Lib\site-packages
PYTHON3_HOME=E:\Python35
PYTHON_HOME=E:\Python27
msg284185 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2016-12-28 17:06
pyreadline is probably the problem. Try uninstalling or updating it.
msg284187 - (view) Author: RĂ¼diger Jungbeck (ruediger.jungbeck@rsj.de) Date: 2016-12-28 17:10
Replacing pyreadline 2.0 with pyreadline 2.1 solved my problems
msg284188 - (view) Author: A.B., Khalid (abkhd) Date: 2016-12-28 17:11
OK. I updated pyreadline to version 2.1 from version 2.0 and now the buggy behavior is gone.

"""
E:\>python
Python 2.7.13 (v2.7.13:a06454b1afa1, Dec 17 2016, 20:53:40) [MSC v.1500 64 bit (AMD64)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>>
"""
History
Date User Action Args
2016-12-28 23:46:18steve.dowersetstatus: open -> closed
resolution: third party
stage: resolved
2016-12-28 17:15:50eryksunsetmessages: - msg284186
2016-12-28 17:11:11abkhdsetmessages: + msg284188
2016-12-28 17:10:09ruediger.jungbeck@rsj.desetmessages: + msg284187
2016-12-28 17:08:09eryksunsetmessages: + msg284186
2016-12-28 17:06:16steve.dowersetmessages: + msg284185
2016-12-28 16:59:21abkhdsetmessages: + msg284183
2016-12-28 16:48:43tim.goldensetmessages: + msg284182
2016-12-28 16:13:50abkhdsetfiles: + python-v.txt

messages: + msg284180
2016-12-28 15:49:03steve.dowersetmessages: + msg284177
2016-12-28 08:30:44abkhdsetmessages: + msg284166
2016-12-28 08:15:07eryksunsetnosy: + eryksun
messages: + msg284162
2016-12-28 07:41:08ruediger.jungbeck@rsj.desetnosy: + ruediger.jungbeck@rsj.de
messages: + msg284159
2016-12-21 19:00:35abkhdcreate