Title: ResourceWarning when imorting antigravity in 3.6
Type: resource usage Stage: resolved
Components: Library (Lib) Versions: Python 3.6
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: brendan-donegan, levkivskyi
Priority: normal Keywords:

Created on 2016-12-15 15:03 by levkivskyi, last changed 2018-01-23 00:06 by levkivskyi. This issue is now closed.

Messages (4)
msg283317 - (view) Author: Ivan Levkivskyi (levkivskyi) * (Python committer) Date: 2016-12-15 15:03
In 3.6 importing antigravity prints a warning (although it does what it should do):

>>> import antigravity
/home/ivan/.../Lib/ ResourceWarning: subprocess 15501 is still running
  ResourceWarning, source=self)

This is probably related to
msg283327 - (view) Author: Brendan Donegan (brendan-donegan) * Date: 2016-12-15 15:35
I think this is essentially a duplicate of, or at least fixing that will fix this (as the exception is caused by the call)
msg289810 - (view) Author: Ivan Levkivskyi (levkivskyi) * (Python committer) Date: 2017-03-18 13:12
It looks like this is fixed on master, but the problem still appears on 3.6
msg310450 - (view) Author: Ivan Levkivskyi (levkivskyi) * (Python committer) Date: 2018-01-23 00:06
I have not seen this for quite some time so I'm closing this as fixed.
Date User Action Args
2018-01-23 00:06:24levkivskyisetstatus: open -> closed
resolution: fixed
messages: + msg310450

stage: resolved
2017-03-18 13:12:06levkivskyisetmessages: + msg289810
2016-12-15 15:35:08brendan-donegansetnosy: + brendan-donegan
messages: + msg283327
2016-12-15 15:03:36levkivskyicreate