classification
Title: AttributeError: module 'signal' has no attribute 'SIGALRM'
Type: Stage: resolved
Components: Versions: Python 3.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: dd, yan12125
Priority: normal Keywords:

Created on 2016-12-12 13:27 by dd, last changed 2016-12-12 14:05 by berker.peksag. This issue is now closed.

Messages (3)
msg282993 - (view) Author: (dd) Date: 2016-12-12 13:27
When I try to run the example at the very end of the signal documentation page [https://docs.python.org/3/library/signal.html#example] I get the error from the title: 
AttributeError: module 'signal' has no attribute 'SIGALRM'

The same thing happens for SIGINT, which is what I was trying to use in the first place.

I found the comment that many things in signal have been turned to enums [https://docs.python.org/3/library/signal.html#module-contents] but they don't seem to be documented anywhere.

I'm not sure if this is an actual bug or if these enums are just not documented, but It would be great if someone could look into this.

I run an up-to-date Manjaro Linux (an Arch-based distro) and Python 3.5.2 (default, Nov  7 2016, 11:31:36) 
[GCC 6.2.1 20160830]

Let me know if anything is unclear.
msg282998 - (view) Author: Chih-Hsuan Yen (yan12125) * Date: 2016-12-12 13:53
Can you import _signal? And what's the output of dir(_signal)?

Another possibility is that there's another signal.py in the search path. Could you also paste the output of repr(signal)?

By the way, here on Arch Linux, both signal.SIGINT and signal.SIGALRM are there.
msg283000 - (view) Author: (dd) Date: 2016-12-12 13:58
Yeah, I'm stupid. I named my file signal.py…

Sorry for the trouble and thanks for your help!
History
Date User Action Args
2016-12-12 14:05:47berker.peksagsetstage: resolved
2016-12-12 13:58:58ddsetstatus: open -> closed
resolution: not a bug
messages: + msg283000
2016-12-12 13:53:09yan12125setnosy: + yan12125
messages: + msg282998
2016-12-12 13:27:27ddcreate