classification
Title: Add fixer for "import exceptions"
Type: enhancement Stage: resolved
Components: 2to3 (2.x to 3.x conversion tool) Versions: Python 3.7, Python 3.6, Python 3.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: 'exceptions' import fixer
View: 2350
Assigned To: Nosy List: Valentin.Lorentz, berker.peksag
Priority: normal Keywords:

Created on 2016-12-09 16:11 by Valentin.Lorentz, last changed 2016-12-09 19:29 by berker.peksag. This issue is now closed.

Files
File name Uploaded Description Edit
fix_import_exceptions.py Valentin.Lorentz, 2016-12-09 16:11 Fixer for "import exceptions"
Messages (2)
msg282787 - (view) Author: ProgVal (Valentin.Lorentz) Date: 2016-12-09 16:11
Hi,

Here is a fixer to remove "import exceptions" from Python 2 code and replace "exceptions.X" with "X".

Valentin
msg282799 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2016-12-09 19:29
Thanks for the report and for the patch! This is a duplicate of issue 2350.

Note that we accept patches from hg.python.org, not standalone Python files. See http://cpython-devguide.readthedocs.io/en/latest/patch.html for details.
History
Date User Action Args
2016-12-09 19:29:58berker.peksagsetstatus: open -> closed

superseder: 'exceptions' import fixer

nosy: + berker.peksag
messages: + msg282799
resolution: duplicate
stage: resolved
2016-12-09 16:11:44Valentin.Lorentzcreate