classification
Title: urllib not handling ftp servers that do not support REST
Type: behavior Stage:
Components: Build Versions: Python 2.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: daggett, gregory.p.smith
Priority: normal Keywords:

Created on 2008-05-16 10:18 by daggett, last changed 2008-05-25 09:00 by gregory.p.smith. This issue is now closed.

Messages (3)
msg66928 - (view) Author: (daggett) Date: 2008-05-16 10:18
I reported a bug in fedora bugzilla :
https://bugzilla.redhat.com/show_bug.cgi?id=443033

I thought this was an Anaconda (Fedora installer written in Python)
error, but someone wrote this is a Python urllib error, so I post it
here to be sure this is a Python error or not.

The bug is:
When downloading a file from an FTP server, it uses the REST command
everytime and don't bother to check if the FTP server supports this command.
So if the FTP server does not support the REST command, the download
just fails and there is no alternative: no mean to download a file.

But it should have detected that the FTP server does not support the
REST command and try to download using the GET command instead.

It happened when net-installing Fedora8 from ftp://ftp.proxad.net which
does not support the REST command (for more information, see the URL to
the bug I submitted to Fedora Bugzilla).

regards,
Dag
msg67221 - (view) Author: (daggett) Date: 2008-05-23 07:44
ok, I've chatted IRC with some Python devs on #python and it seems that
it's a python-urlgrabber (yum package manager) issue so I'll reassign my
redhat bug report.
msg67333 - (view) Author: Gregory P. Smith (gregory.p.smith) * (Python committer) Date: 2008-05-25 09:00
I believe that means we can close this issue here?  If not, please reopen.
History
Date User Action Args
2008-05-25 09:00:08gregory.p.smithsetstatus: open -> closed
resolution: not a bug
messages: + msg67333
nosy: + gregory.p.smith
2008-05-23 07:44:34daggettsetmessages: + msg67221
2008-05-16 10:18:47daggettcreate