classification
Title: IDLE needs the ability to pass in command-line arguments
Type: enhancement Stage: resolved
Components: IDLE Versions: Python 3.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Simulate command-line arguments for program run in IDLE
View: 5680
Assigned To: terry.reedy Nosy List: louielu, rhettinger, terry.reedy
Priority: normal Keywords:

Created on 2016-12-06 19:02 by rhettinger, last changed 2017-06-20 21:23 by terry.reedy. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 1589 open louielu, 2017-05-15 06:49
Messages (3)
msg282567 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2016-12-06 19:02
[--- Feature request posted on behalf of Balakrishnan Sakthidharan ---]

IDLE lets you run scripts with F5.

What is needs is an F6 that opens a dialog box and asks for command-line arguments.  This will help develop and test command line scripts in the IDE.

  F6 -q5 -v=8 somefile.txt
msg293680 - (view) Author: Louie Lu (louielu) * Date: 2017-05-15 06:51
This PR will add the short-key to F7, when using editor. It will prompt up a dialog and user can input the command-line arguments then run the code.
msg296489 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2017-06-20 21:23
Another duplicate of #5680, which already has three patches.  I retitled the PR and it is now listed on #5680.
History
Date User Action Args
2017-06-20 21:23:50terry.reedysetstatus: open -> closed
superseder: Simulate command-line arguments for program run in IDLE
messages: + msg296489

resolution: duplicate
stage: resolved
2017-05-15 06:51:35louielusetnosy: + louielu
messages: + msg293680
2017-05-15 06:49:44louielusetpull_requests: + pull_request1682
2016-12-06 19:02:26rhettingercreate