classification
Title: test_unittest failures when refleak hunting
Type: behavior Stage: resolved
Components: Versions: Python 3.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: test_unittest failure in leaks searching mode
View: 25746
Assigned To: Nosy List: ncoghlan, ned.deily, serhiy.storchaka
Priority: normal Keywords:

Created on 2016-12-05 07:10 by ncoghlan, last changed 2016-12-05 19:42 by ned.deily. This issue is now closed.

Messages (3)
msg282390 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2016-12-05 07:10
test_unittest currently fails for me when hunting refleaks (Fedora 25):

$ ./python -m test -R 3:3 -v test_unittest

======================================================================
ERROR: test_discover_with_init_module_that_raises_SkipTest_on_import (unittest.test.test_discovery.TestDiscovery)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/ncoghlan/devel/py36/Lib/unittest/test/test_discovery.py", line 572, in test_discover_with_init_module_that_raises_SkipTest_on_import
    pickle.loads(pickle.dumps(suite, proto))
_pickle.PicklingError: Can't pickle <class 'unittest.loader.ModuleSkipped'>: attribute lookup ModuleSkipped on unittest.loader failed

======================================================================
ERROR: test_discover_with_module_that_raises_SkipTest_on_import (unittest.test.test_discovery.TestDiscovery)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/ncoghlan/devel/py36/Lib/unittest/test/test_discovery.py", line 548, in test_discover_with_module_that_raises_SkipTest_on_import
    pickle.loads(pickle.dumps(suite, proto))
_pickle.PicklingError: Can't pickle <class 'unittest.loader.ModuleSkipped'>: attribute lookup ModuleSkipped on unittest.loader failed

----------------------------------------------------------------------
Ran 715 tests in 1.898s

FAILED (errors=2, skipped=7)
msg282393 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2016-12-05 07:25
Ned, I'm not sure if this should be a release blocker or not.

Superficially, it looks like it's just a test bug arising from running the test multiple times in the same process, but I unfortunately don't have time to investigate further today.
msg282394 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2016-12-05 07:32
This is a duplicate of issue25746.
History
Date User Action Args
2016-12-05 19:42:22ned.deilysetassignee: ned.deily ->
2016-12-05 12:00:51berker.peksagsetstatus: open -> closed
stage: needs patch -> resolved
2016-12-05 07:32:55serhiy.storchakasetnosy: + serhiy.storchaka
messages: + msg282394
resolution: duplicate

superseder: test_unittest failure in leaks searching mode
2016-12-05 07:25:46ncoghlansetassignee: ned.deily
messages: + msg282393
2016-12-05 07:10:34ncoghlansetnosy: + ned.deily
2016-12-05 07:10:24ncoghlancreate