classification
Title: test_builtin failures when refleak hunting
Type: behavior Stage: resolved
Components: Versions: Python 3.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: readline-related test_builtin failure
View: 13886
Assigned To: Nosy List: ncoghlan, ned.deily, serhiy.storchaka
Priority: normal Keywords:

Created on 2016-12-05 07:08 by ncoghlan, last changed 2016-12-05 19:41 by ned.deily. This issue is now closed.

Messages (3)
msg282389 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2016-12-05 07:08
test_builtin currently fails for me when hunting refleaks (Fedora 25):

$ ./python -m test -R 3:3 -v test_builtin

[snip]

======================================================================
FAIL: test_input_tty_non_ascii (test.test_builtin.PtyTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/ncoghlan/devel/py36/Lib/test/test_builtin.py", line 1592, in test_input_tty_non_ascii
    self.check_input_tty("prompté", b"quux\xe9", "utf-8")
  File "/home/ncoghlan/devel/py36/Lib/test/test_builtin.py", line 1583, in check_input_tty
    self.assertEqual(input_result, expected)
AssertionError: 'quux' != 'quux\udce9'
- quux
+ quux\udce9
?     +


======================================================================
FAIL: test_input_tty_non_ascii_unicode_errors (test.test_builtin.PtyTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/ncoghlan/devel/py36/Lib/test/test_builtin.py", line 1596, in test_input_tty_non_ascii_unicode_errors
    self.check_input_tty("prompté", b"quux\xe9", "ascii")
  File "/home/ncoghlan/devel/py36/Lib/test/test_builtin.py", line 1583, in check_input_tty
    self.assertEqual(input_result, expected)
AssertionError: 'quux' != 'quux\udce9'
- quux
+ quux\udce9
?     +


----------------------------------------------------------------------
Ran 78 tests in 0.066s

FAILED (failures=2)
msg282392 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2016-12-05 07:25
Ned, I'm not sure if this should be a release blocker or not.

Superficially, it looks like it's just a test bug arising from running the test multiple times in the same process, but I unfortunately don't have time to investigate further today.
msg282395 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2016-12-05 07:35
This is a duplicate of issue13886.
History
Date User Action Args
2016-12-05 19:41:14ned.deilysetstatus: open -> closed
assignee: ned.deily ->
stage: needs patch -> resolved
2016-12-05 07:35:23serhiy.storchakasetnosy: + serhiy.storchaka
messages: + msg282395
resolution: duplicate

superseder: readline-related test_builtin failure
2016-12-05 07:25:08ncoghlansetassignee: ned.deily
messages: + msg282392
2016-12-05 07:08:43ncoghlancreate