classification
Title: mention asyncio.gather non-deterministic task starting order
Type: enhancement Stage: resolved
Components: Documentation Versions: Python 3.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: asyncio docs overhaul
View: 33649
Assigned To: docs@python Nosy List: Soren Solari, cheryl.sabella, docs@python
Priority: normal Keywords:

Created on 2016-11-26 18:05 by Soren Solari, last changed 2019-04-12 20:27 by cheryl.sabella. This issue is now closed.

Messages (2)
msg281787 - (view) Author: Soren Solari (Soren Solari) Date: 2016-11-26 18:05
https://github.com/python/asyncio/issues/432

asyncio.gather documentation states:
"the returned future’s result is the list of results (in the order of the original sequence, not necessarily the order of results arrival)"

An additional statement like "tasks are not guaranteed to be started in a predicable order" would aid users and slove the discussion in issue 432 above.
msg340109 - (view) Author: Cheryl Sabella (cheryl.sabella) * (Python committer) Date: 2019-04-12 20:27
I believe the issue mentioned here was addressed by the doc rewrite in issue 33649.  I'm going to mark this as a duplicate of that issue, but if the concern here still exists, then please re-open this issue.
History
Date User Action Args
2019-04-12 20:27:58cheryl.sabellasetstatus: open -> closed

superseder: asyncio docs overhaul

nosy: + cheryl.sabella
messages: + msg340109
resolution: duplicate
stage: resolved
2016-11-26 18:05:22Soren Solaricreate