classification
Title: about PEP 528 / PEP 529
Type: Stage: resolved
Components: Windows Versions: Python 3.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Big Stone, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2016-11-12 19:05 by Big Stone, last changed 2016-12-28 23:38 by steve.dower. This issue is now closed.

Files
File name Uploaded Description Edit
pep_528-529_where_are_you_you.PNG Big Stone, 2016-11-12 19:08
Messages (3)
msg280667 - (view) Author: Big Stone (Big Stone) Date: 2016-11-12 19:05
Hi, if possible a few words of explanation to implement it may be helpfull, as I don't see the difference yet, in the typical case where it was not good before:
https://cloud.githubusercontent.com/assets/4312421/20240181/5bf917fe-a912-11e6-95e8-e65fcb9a8845.PNG

(more an after PEP sales service request than a bug, I presume)
msg280668 - (view) Author: Big Stone (Big Stone) Date: 2016-11-12 19:08
same un-effect in Qtconsole, I'm disappointed. Maybe I mis-understood what these PEP would bring ?
msg280680 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2016-11-13 01:43
Those are redirecting stdin and stdout from the real console to their own handlers, so they are responsible for setting the encoding. Both of those examples are able to fix the encoding issues whenever they like - assuming their GUI toolkits can handle it.

The change for 3.6 only affected the standard Windows console. Other consoles can specify a different encoding independently.
History
Date User Action Args
2016-12-28 23:38:56steve.dowersetstatus: open -> closed
resolution: not a bug
stage: resolved
2016-11-13 01:43:47steve.dowersetmessages: + msg280680
2016-11-12 19:08:08Big Stonesetfiles: + pep_528-529_where_are_you_you.PNG

messages: + msg280668
2016-11-12 19:05:03Big Stonecreate