classification
Title: AboutDialog set_name is ignored
Type: behavior Stage: resolved
Components: Versions: Python 3.5
process
Status: closed Resolution: third party
Dependencies: Superseder:
Assigned To: Nosy List: rebelxt, zach.ware
Priority: normal Keywords:

Created on 2016-11-03 15:47 by rebelxt, last changed 2016-11-03 15:54 by zach.ware. This issue is now closed.

Messages (2)
msg279998 - (view) Author: (rebelxt) Date: 2016-11-03 15:47
Python 3.5.2 (default, Sep 10 2016, 08:21:44) [GCC 5.4.0 20160609] on linux Mint 18 and Gtk 3.

I run a python3 script that includes these statements:

import gi
gi.require_version('Gtk', '3.0')
from gi.repository import Gtk, GObject
aboutdialog = Gtk.AboutDialog()
aboutdialog.set_name('arbitrary')
aboutdialog.run()
aboutdialog.destroy()

The script name is displayed in the About dialog, while the 'arbitrary' name is ignored. This is inconsistent with python2/gtk2. If the set_name method/function exists, it should do something.

I have no way of testing this on any later version of python.
msg279999 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2016-11-03 15:53
That appears to be an issue with the third-party PyGObject project, please open an issue on the PyGObject issue tracker: https://bugzilla.gnome.org/page.cgi?id=browse.html&product=pygobject
History
Date User Action Args
2016-11-03 15:54:43zach.waresetresolution: not a bug -> third party
2016-11-03 15:53:39zach.waresetstatus: open -> closed

nosy: + zach.ware
messages: + msg279999

resolution: not a bug
stage: resolved
2016-11-03 15:47:58rebelxtcreate