classification
Title: get error when compile .py file during install stage if cross compile
Type: compile error Stage:
Components: Cross-Build Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: Alex.Willmer, DiazSoho, doko, xdegaye
Priority: normal Keywords:

Created on 2016-11-02 14:14 by DiazSoho, last changed 2016-11-02 19:38 by xdegaye. This issue is now closed.

Messages (2)
msg279926 - (view) Author: DiazSoho (DiazSoho) Date: 2016-11-02 14:14
when I try to do cross compile Python-2.7.12, it gets error when trying install. because the command is using compile host python to compile .py file with *.so files, but the *.so are built by cross platform toolchain already, then it will say "cannot open shared object file: No such file or directory"
the log is below:

PYTHONPATH=/home/real_users/avs_py/Python/py_install/usr/local/lib/python2.7   \
	_PYTHON_PROJECT_BASE=/home/real_users/avs_py/Python/Python-2.7.12 _PYTHON_HOST_PLATFORM=linux2-mips PYTHONPATH=/home/real_users/avs_py/Python/Python-2.7.12/build/lib.linux2-mips-2.7:/home/real_users/avs_py/Python/Python-2.7.12/Lib:/home/real_users/avs_py/Python/Python-2.7.12/Lib/plat-linux2 python2.7 -Wi -tt /home/real_users/avs_py/Python/py_install/usr/local/lib/python2.7/compileall.py \
	-d /home/real_users/avs_py/Python/py_install/usr/local/lib/python2.7 -f \
	-x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
	/home/real_users/avs_py/Python/py_install/usr/local/lib/python2.7
Traceback (most recent call last):
  File "/home/real_users/avs_py/Python/py_install/usr/local/lib/python2.7/compileall.py", line 16, in <module>
    import struct
  File "/home/real_users/avs_py/Python/py_install/usr/local/lib/python2.7/struct.py", line 1, in <module>
    from _struct import *
ImportError: /home/real_users/avs_py/Python/Python-2.7.12/build/lib.linux2-mips-2.7/_struct.so: cannot open shared object file: No such file or directory
make[5]: *** [libinstall] Error 1
msg279939 - (view) Author: Xavier de Gaye (xdegaye) * (Python triager) Date: 2016-11-02 19:38
msg269617 details how this problem can also be reproduced on 3.6 by cross-building for Android before the issue 27917 that added platform triplets for Android had been fixed.

Since the changes in issue 23968 have not be retrofited to 3.5, the same problem must also exist on 3.5.  Closing this issue as a duplicate of issue 22724.
History
Date User Action Args
2016-11-02 19:38:00xdegayesetstatus: open -> closed
resolution: duplicate
messages: + msg279939
2016-11-02 14:15:02vstinnersetnosy: + doko, xdegaye
2016-11-02 14:14:05DiazSohocreate