classification
Title: Windows: _socket module fails to compile on "AMD64 Windows7 SP1 3.x" buildbot "because "AlwaysCreate" was specified"
Type: compile error Stage: resolved
Components: Windows Versions: Python 3.7, Python 3.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: jkloth, paul.moore, steve.dower, tim.golden, vstinner, zach.ware
Priority: normal Keywords:

Created on 2016-10-29 07:13 by vstinner, last changed 2017-06-28 01:01 by vstinner. This issue is now closed.

Messages (6)
msg279658 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2016-10-29 07:13
It looks like the build 8776 was fine, but compilation of _socket started to fail near the build:

http://buildbot.python.org/all/builders/AMD64%20Windows7%20SP1%203.x/builds/8777

The related change 16ea07d420b864d786ef9c11a07967fe19c3a9cd seems unrelated.
msg279659 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2016-10-29 07:17
Interesting message: "because "AlwaysCreate" was specified".

Extract of a failed build:

         Touching "C:\buildbot.python.org\3.x.kloth-win64\build\PCbuild\obj\\amd64_Debug\_sqlite3\_sqlite3.tlog\_sqlite3.lastbuildstate".
    29>Done Building Project "C:\buildbot.python.org\3.x.kloth-win64\build\PCbuild\_sqlite3.vcxproj" (Build target(s)).
    32>ClCompile:
         All outputs are up-to-date.
       The target "BeforeGenerateProjectPriFile" listed in a BeforeTargets attribute at "C:\Program Files (x86)\MSBuild\Microsoft\NuGet\Microsoft.NuGet.targets (186,61)" does not exist in the project, and will be ignored.
    33>GeneratePythonNtRcH:
       Skipping target "GeneratePythonNtRcH" because all output files are up-to-date with respect to the input files.
       ClCompile:
         All outputs are up-to-date.
    31>Project "C:\buildbot.python.org\3.x.kloth-win64\build\PCbuild\_ssl.vcxproj" (31) is building "C:\buildbot.python.org\3.x.kloth-win64\build\PCbuild\_socket.vcxproj" (34) on node 2 (default targets).
    34>InitializeBuildStatus:
         Creating "C:\buildbot.python.org\3.x.kloth-win64\build\PCbuild\obj\\amd64_Debug\_socket\_socket.tlog\unsuccessfulbuild" because "AlwaysCreate" was specified.
       GeneratePythonNtRcH:
       Skipping target "GeneratePythonNtRcH" because all output files are up-to-date with respect to the input files.
       ClCompile:
         C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin\amd64\CL.exe /c /I"C:\buildbot.python.org\3.x.kloth-win64\build\Include" /I"C:\buildbot.python.org\3.x.kloth-win64\build\PC" /I"C:\buildbot.python.org\3.x.kloth-win64\build\PCbuild\obj\\amd64_Debug\_socket\\" /Zi /nologo /W3 /WX- /Od /Oi /D WIN32 /D _WIN64 /D _M_X64 /D _DEBUG /D Py_BUILD_CORE_MODULE /D _WINDLL /GF /Gm- /MDd /GS /Gy /fp:precise /Zc:wchar_t /Zc:forScope /Zc:inline /Fo"C:\buildbot.python.org\3.x.kloth-win64\build\PCbuild\obj\\amd64_Debug\_socket\\" /Fd"C:\buildbot.python.org\3.x.kloth-win64\build\PCbuild\obj\\amd64_Debug\_socket\vc140.pdb" /Gd /TC /errorReport:queue ..\Modules\socketmodule.c
    33>Lib:
         All outputs are up-to-date.
         ssleay.vcxproj -> C:\buildbot.python.org\3.x.kloth-win64\build\PCBuild\amd64\ssleay_d.lib
    34>ClCompile:
         socketmodule.c
       The target "BeforeGenerateProjectPriFile" listed in a BeforeTargets attribute at "C:\Program Files (x86)\MSBuild\Microsoft\NuGet\Microsoft.NuGet.targets (186,61)" does not exist in the project, and will be ignored.
    32>Lib:
         All outputs are up-to-date.
    33>FinalizeBuildStatus:
         Deleting file "C:\buildbot.python.org\3.x.kloth-win64\build\externals\openssl-1.0.2j\tmp\\amd64_Debug\ssleay\ssleay.tlog\unsuccessfulbuild".
         Touching "C:\buildbot.python.org\3.x.kloth-win64\build\externals\openssl-1.0.2j\tmp\\amd64_Debug\ssleay\ssleay.tlog\ssleay.lastbuildstate".
    33>Done Building Project "C:\buildbot.python.org\3.x.kloth-win64\build\PCbuild\ssleay.vcxproj" (default targets).
    32>Lib:
msg279679 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2016-10-29 15:35
I don't think the build failed, what's more likely is that my recent test_site additions (to test restricted sys.path) are not cleaning up correctly and that's leading to other issue.

I've emailed Jeremy to check the buildbot, and I'm working on making those tests more safe in case they abort without cleaning up.
msg279681 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2016-10-29 15:52
Forgot to include the issue number in the commit message, but 0c910ea1c968 has the test improvements (whether or not they'll help here remains to be seen... I added some extra cleanup to rt.bat that might help the buildbots recover if this was the issue).
msg279688 - (view) Author: Jeremy Kloth (jkloth) * Date: 2016-10-29 17:52
Steve's guess wrt the _pth file being the cause was spot on.  The buildbot is back on track with successful results.
msg297095 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-06-28 01:01
Windows buildbots are now fine. It seems like the bug was fixed ;-)
History
Date User Action Args
2017-06-28 01:01:18vstinnersetstatus: open -> closed
resolution: fixed
messages: + msg297095

stage: resolved
2016-10-29 17:52:40jklothsetnosy: + jkloth
messages: + msg279688
2016-10-29 15:52:56steve.dowersetmessages: + msg279681
versions: + Python 3.6
2016-10-29 15:35:49steve.dowersetmessages: + msg279679
2016-10-29 07:17:48vstinnersetmessages: + msg279659
title: Windows: _socket module fails to compile on "AMD64 Windows7 SP1 3.x" buildbot -> Windows: _socket module fails to compile on "AMD64 Windows7 SP1 3.x" buildbot "because "AlwaysCreate" was specified"
2016-10-29 07:13:51vstinnercreate