classification
Title: Regenerate ./configure on the default branch
Type: behavior Stage: resolved
Components: Build Versions: Python 3.7
process
Status: closed Resolution: later
Dependencies: Superseder:
Assigned To: Nosy List: benjamin.peterson, dilyan.palauzov, ned.deily, yan12125
Priority: normal Keywords:

Created on 2016-10-22 16:56 by yan12125, last changed 2017-10-13 16:16 by dilyan.palauzov. This issue is now closed.

Messages (8)
msg279204 - (view) Author: Chih-Hsuan Yen (yan12125) * Date: 2016-10-22 16:56
In 0ea088671bc2 and 3ce29b2452f0, --runstatedir was added to ./configure. Seems Benjamin uses a slightly different version of autoconf than 2.69. As a result, modifying ./configure.ac leads to unrelated changes in ./configure. Later in 17bd5239b886, this option is removed from 3.6 branch. The issue is still in the default branch. Can anyone apply 17bd5239b886 to the default branch?

Added authors of aforementioned commits.
msg279205 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2016-10-22 17:04
Don't worry about it. We will take care of it as necessary when we release.
msg279206 - (view) Author: Chih-Hsuan Yen (yan12125) * Date: 2016-10-22 17:14
Thanks for the fast response. My main point is not that would affect users who compile from tarballs. The point is that if I modify configure.ac on the default branch, I can't generate a patch that applies to the default branch cleanly; there are always --runstatedir related changes, so line numbers are incorrect. Seems Rietveld doesn't handle patches with wrong line numbers. An example is ncurses.patch of issue28190.
msg279212 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2016-10-22 18:57
That's why we suggest to not include configure changes in a patch, only configure.ac changes. It's the responsibility of the patch committer to ensure that generated files like configure are updated properly at commit time. But, yes, it would be better to not have spurious changes go in and out.
msg279213 - (view) Author: Chih-Hsuan Yen (yan12125) * Date: 2016-10-22 19:03
Well, I remember someone asked me to include ./configure in patches. Maybe it's worth to add a comment in devguide.
msg279221 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2016-10-22 21:15
https://docs.python.org/devguide/faq.html#how-do-i-regenerate-configure
msg279222 - (view) Author: Chih-Hsuan Yen (yan12125) * Date: 2016-10-22 21:30
Thanks. Sorry for not reading devguide carefully.
msg304344 - (view) Author: Дилян Палаузов (dilyan.palauzov) Date: 2017-10-13 16:16
For the record, on master runstatedir was added on 7th September 2017, removed on 5th September, added on 29 June, removed on 9th June, added on 14th April, removed on 6th December 2016 and 10th October in two branches, added on 13th September...

The history would be easier to understand and follow, if one clarifies whether runstatedir belongs to configure and then everybody sticks to the same rule.

Autoconf 2.69 does not insert runstatedir, autoconf.git since 12 September 2013 does insert runstatedir.
History
Date User Action Args
2017-10-13 16:16:54dilyan.palauzovsetnosy: + dilyan.palauzov
messages: + msg304344
2016-10-22 21:30:37yan12125setmessages: + msg279222
2016-10-22 21:15:07ned.deilysetmessages: + msg279221
2016-10-22 19:03:48yan12125setmessages: + msg279213
2016-10-22 18:57:03ned.deilysetmessages: + msg279212
2016-10-22 17:14:10yan12125setmessages: + msg279206
2016-10-22 17:04:20ned.deilysetstatus: open -> closed
resolution: later
messages: + msg279205

stage: resolved
2016-10-22 16:56:10yan12125create