classification
Title: pip installation issues with default path on Windows
Type: behavior Stage: resolved
Components: Installation Versions: Python 3.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Wojtek Swiatek, eryksun
Priority: normal Keywords:

Created on 2016-10-22 15:47 by Wojtek Swiatek, last changed 2016-10-22 19:08 by eryksun. This issue is now closed.

Messages (2)
msg279199 - (view) Author: Wojtek Swiatek (Wojtek Swiatek) Date: 2016-10-22 15:47
When installing Python 3.5 on Windows (I checked the 64bits installer but I believe the same issue will be with the 32bits), the default installation path when installing for "everyone" is now C:\ Program Files\Python35.

When subsequently installing packages via pip, the installation crashes midway with a cryptic error about "permission denied" (if I remember correctly). I checked with the cryptography module.

It is not an issue with access rights but with the whitespace in "Program Files". Reinstalling Python to C:\Python35 fixes the issue (pip install cryptography runs correctly).
msg279214 - (view) Author: Eryk Sun (eryksun) * (Python triager) Date: 2016-10-22 19:08
Issues with pip should be reported to its GitHub site. But installing to the "Program Files" directory certainly isn't a problem for pip. You need to run it with administrator rights.
History
Date User Action Args
2016-10-22 19:08:47eryksunsetstatus: open -> closed

nosy: + eryksun
messages: + msg279214

resolution: not a bug
stage: resolved
2016-10-22 15:47:17Wojtek Swiatekcreate