classification
Title: inappropriate OS.Error "Invalid cross-device link"
Type: Stage: resolved
Components: IO Versions: Python 3.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: steve.newcomb
Priority: normal Keywords:

Created on 2016-10-20 18:03 by steve.newcomb, last changed 2016-10-20 18:25 by eryksun. This issue is now closed.

Messages (2)
msg279061 - (view) Author: Steve Newcomb (steve.newcomb) * Date: 2016-10-20 18:03
os.rename() raises OSError with a misleading message saying "cross-device" when no cross-device activity is involved.  

Here, running on Ubuntu 16.04.1 using and ext4 filesystem, both filepaths are in the same filesystem, and the error is evidently due to the fact that a file already exists at the target path:

(Pdb) os.path.isfile( '/persist/nobackup/backupDisks/d38BasLijPupBak/d38-backup.20161020/d38-_,.,_home2_,.,_rack/.Xauthority')
True
(Pdb) os.path.isfile( '/persist/nobackup/backupDisks/d38BasLijPupBak/d38-20161020/home2/rack/.Xauthority')
True
(Pdb) os.rename( '/persist/nobackup/backupDisks/d38BasLijPupBak/d38-backup.20161020/d38-_,.,_home2_,.,_rack/.Xauthority', '/persist/nobackup/backupDisks/d38BasLijPupBak/d38-20161020/home2/rack/.Xauthor\
ity')
*** OSError: [Errno 18] Invalid cross-device link: '/persist/nobackup/backupDisks/d38BasLijPupBak/d38-backup.20161020/d38-_,.,_home2_,.,_rack/.Xauthority' -> '/persist/nobackup/backupDisks/d38BasLijPup\
Bak/d38-20161020/home2/rack/.Xauthority'
msg279062 - (view) Author: Steve Newcomb (steve.newcomb) * Date: 2016-10-20 18:21
Oops.  My bad.  There was a symlink in one of those paths.  The message is valid.
History
Date User Action Args
2016-10-20 18:25:32eryksunsetstage: resolved
2016-10-20 18:21:49steve.newcombsetstatus: open -> closed
resolution: not a bug
messages: + msg279062
2016-10-20 18:03:19steve.newcombcreate