classification
Title: Dictionary methods: inconsistency
Type: Stage:
Components: Versions: Python 3.0
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: chester, gvanrossum, loewis
Priority: normal Keywords:

Created on 2008-05-12 21:11 by chester, last changed 2008-05-12 21:32 by gvanrossum. This issue is now closed.

Messages (4)
msg66758 - (view) Author: Chester (chester) Date: 2008-05-12 21:11
Names of dictionary methods are not consistent with Python's coding
style. Please fix the following method names:

1) fix    deepcopy    to be  deep_copy
2) fix    fromkeys    to be  from_keys
3) fix    popitem     to be  pop_item
4) fix    setdefault  to be  set_default

Please consider of renaming the method copy to shallow_copy. If you find
any other inconsistently named method, please fix it. Thank you.
msg66759 - (view) Author: Fredrik Lundh (effbot) * (Python committer) Date: 2008-05-12 21:17
Eh?  Why did you add *everyone* involved the project to the nosy list?

(I'll leave explaining why breaking almost all Python programs in the
name of "consistency" is an absurd idea to someone else).
msg66760 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-05-12 21:25
Rejecting as "invalid". If you somehow still think something should
change, please discuss that on the py3k list.
msg66761 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2008-05-12 21:32
Chester, this is your last warning.  One more submission like this and
we will ban you from submitting new bug reports.  You have to learn how
to use the bug tracker properly if you don't want to be ignored completely.
History
Date User Action Args
2008-05-12 21:32:36gvanrossumsetnosy: + gvanrossum
messages: + msg66761
2008-05-12 21:25:19loewissetstatus: open -> closed
nosy: + loewis, chester
resolution: not a bug
messages: + msg66760
2008-05-12 21:17:56effbotsetnosy: - effbot
2008-05-12 21:17:33effbotsetnosy: - admin, anonymous, mwh, lemburg, gvanrossum, tim.peters, nobody, loewis, jhylton, mhammond, sjoerd, fdrake, twouters, skip.montanaro, ping, viznut, moshez, barry, akuchling, aaronsw, doerwalter, mpmak, tmick, memaul, chester
messages: + msg66759
2008-05-12 21:11:53chestercreate