classification
Title: Deprecation warning doesn't stand out enough
Type: Stage: resolved
Components: Documentation Versions: Python 3.7, Python 3.6, Python 3.4, Python 3.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: Mariatta, berker.peksag, docs@python, methane, r.david.murray
Priority: normal Keywords:

Created on 2016-10-05 05:56 by Mariatta, last changed 2016-10-05 12:59 by r.david.murray. This issue is now closed.

Messages (4)
msg278103 - (view) Author: Mariatta (Mariatta) * (Python committer) Date: 2016-10-05 05:56
In documentation for python 3.3, the deprecation warning is rendered in a red box which is more eye-catching.

eg https://docs.python.org/3.3/library/imp.html?highlight=imp#module-imp

But since python 3.4 onwards, seems like the red box disappears and the deprecation warning message no longer stands out.

for example
https://docs.python.org/3.4/library/imp.html?highlight=imp#module-imp

I kinda prefer like the older style (with the red box).
msg278104 - (view) Author: Inada Naoki (methane) * (Python committer) Date: 2016-10-05 06:29
default.css was changed?
https://docs.python.org/3.3/_static/default.css
https://docs.python.org/3.4/_static/default.css
msg278105 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2016-10-05 06:32
It was rendered in a red box, because we were using an old Sphinx CSS file (Doc/tools/static/basic.css) [1] We are using Sphinx defaults now and Python specific tweaks are located at Doc/tools/pydoctheme/static/pydoctheme.css.

We usually prefer to use less disruptive visual elements (including using less gray note directives) in Python documentation. The exception to this is security warnings. See https://docs.python.org/3.5/library/xml.html and https://docs.python.org/3.5/library/ssl.html for example.

I recommend to close this as "wont fix".

[1] Removed in https://github.com/python/cpython/commit/7c366a72ac56814edaf3fb2718b08441aff31d3a
msg278121 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2016-10-05 12:59
Agreed. The removal of the red was a conscious choice.  As I remember it, that choice got reflected into the Sphinx defaults, rather than the other way around :)
History
Date User Action Args
2016-10-05 12:59:28r.david.murraysetstatus: open -> closed

nosy: + r.david.murray
messages: + msg278121

resolution: not a bug
stage: resolved
2016-10-05 06:32:33berker.peksagsetnosy: + berker.peksag
messages: + msg278105
2016-10-05 06:29:25methanesetnosy: + methane
messages: + msg278104
2016-10-05 05:56:10Mariattacreate