classification
Title: 3.6 source doesn't build on centos 6
Type: compile error Stage: resolved
Components: Build Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: berker.peksag, lurker10
Priority: normal Keywords:

Created on 2016-10-03 08:37 by lurker10, last changed 2016-10-03 10:15 by berker.peksag. This issue is now closed.

Messages (7)
msg277937 - (view) Author: (lurker10) Date: 2016-10-03 08:37
Centos 6.7
Python 2.6.6 (default in Centos 6, no other python installed)
GCC 4.4.7

# ./configure
...
(no errors)

# make
python ./Tools/scripts/generate_opcode_h.py ./Lib/opcode.py ./Include/opcode.h
/bin/mkdir -p Include
python ./Parser/asdl_c.py -h Include ./Parser/Python.asdl
Traceback (most recent call last):
  File "./Parser/asdl_c.py", line 6, in <module>
    import asdl
  File "/root/cpython/Parser/asdl.py", line 36
    builtin_types = {'identifier', 'string', 'bytes', 'int', 'object', 'singleton',
                                 ^

SyntaxError: invalid syntax
make: *** [Include/Python-ast.h] Error 1
msg277938 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2016-10-03 08:57
Thanks for the report. I think you need to run "make touch".
msg277940 - (view) Author: (lurker10) Date: 2016-10-03 09:00
I am sorry, it's actually 3.7.0a1 I was trying to build that errors.

3.6.0b1 builds fine.
msg277942 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2016-10-03 09:06
Running

    make distclean
    make touch

should solve your problem. There isn't any significant change between 3.6.0b1 and 3.7.0a1 to cause build problems if I recall correctly.
msg277945 - (view) Author: (lurker10) Date: 2016-10-03 09:40
Ok, a new error when running make touch.
Not a mercurial directory (no .hg found). I am not familiar with mercurial though, could be an easy fix.
It happens for both 3.7.0a1 and for the current 3.6 branch.

It's alright I'll just use the 3.6.0b1 from the official site.
msg277947 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2016-10-03 09:56
How did you get 3.7.0a1? I assumed you cloned it from hg.python.org. If you clone it from the GitHub mirror, you can use the trick mentioned at http://bugs.python.org/issue23404#msg275285
msg277948 - (view) Author: (lurker10) Date: 2016-10-03 10:03
This has to be it, thank you! I used github to get source.
History
Date User Action Args
2016-10-03 10:15:50berker.peksagsetstage: resolved
2016-10-03 10:03:33lurker10setstatus: open -> closed
resolution: not a bug
messages: + msg277948
2016-10-03 09:56:07berker.peksagsetmessages: + msg277947
2016-10-03 09:40:20lurker10setmessages: + msg277945
2016-10-03 09:06:24berker.peksagsetmessages: + msg277942
2016-10-03 09:00:19lurker10setmessages: + msg277940
2016-10-03 08:57:27berker.peksagsetnosy: + berker.peksag
messages: + msg277938
2016-10-03 08:37:07lurker10create