classification
Title: Make error for Python3.6 on Cygwin
Type: compile error Stage: resolved
Components: Build Versions: Python 3.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Cygwin does not provide siginfo_t.si_band
View: 21085
Assigned To: Nosy List: christian.heimes, r.david.murray, ronbarak
Priority: normal Keywords:

Created on 2016-09-28 18:31 by ronbarak, last changed 2016-09-28 19:31 by r.david.murray. This issue is now closed.

Files
File name Uploaded Description Edit
python3.6Make.err.txt ronbarak, 2016-09-28 18:31 All output from `make profile-opt`
Messages (6)
msg277650 - (view) Author: Ron Barak (ronbarak) * Date: 2016-09-28 18:31
Successfully did:

$ gunzip Python-3.6.0b1.tgz
$ tar xvf Python-3.6.0b1.tar
$ pushd Python-3.6.0b1
$ ./configure --disable-ipv6 --with-optimizations

However, when trying to do:

$ make profile-opt

I get:

...

gcc -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes    -std=c99 -Wextra -Wno-unused-result -Wno-unused-parameter -Wno-missing-field-initializers -fprofile-generate   -I. -IInclude -I./Include    -DPy_BUILD_CORE  -c ./Modules/signalmodule.c -o Modules/signalmodule.o
In file included from Include/Python.h:85:0,
                 from ./Modules/signalmodule.c:6:
./Modules/signalmodule.c: In function 'fill_siginfo':
./Modules/signalmodule.c:960:60: error: 'siginfo_t {aka struct <anonymous>}' has no member named 'si_band'
     PyStructSequence_SET_ITEM(result, 6, PyLong_FromLong(si->si_band));
                                                            ^
Include/tupleobject.h:62:75: note: in definition of macro 'PyTuple_SET_ITEM'
 #define PyTuple_SET_ITEM(op, i, v) (((PyTupleObject *)(op))->ob_item[i] = v)
                                                                           ^
./Modules/signalmodule.c:960:5: note: in expansion of macro 'PyStructSequence_SET_ITEM'
     PyStructSequence_SET_ITEM(result, 6, PyLong_FromLong(si->si_band));
     ^
make[2]: *** [Makefile:1731: Modules/signalmodule.o] Error 1
make[2]: Leaving directory '/home/Administrator/python/3.6/Python-3.6.0b1'
make[1]: *** [Makefile:511: build_all_generate_profile] Error 2
make[1]: Leaving directory '/home/Administrator/python/3.6/Python-3.6.0b1'
make: *** [Makefile:496: profile-opt] Error 2
msg277651 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2016-09-28 18:59
Cygwin is an unsupported platform. It seems like Cygwin broke siginfo_t. The struct must have a si_band member, see http://man7.org/linux/man-pages/man2/rt_sigaction.2.html .
msg277653 - (view) Author: Ron Barak (ronbarak) * Date: 2016-09-28 19:09
Re: Cygwin is an unsupported platform. 

Currently, from the contents of Python-3.6.0b1, one may be led to believe that Cygwin _is_ supported, e.g. - see the references to Cygwin in the README file:

$ grep -i cygwin README
On Unix, Linux, BSD, OSX, and Cygwin:
find out more.  On OSX and Cygwin, the executable is called python.exe;
msg277654 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2016-09-28 19:13
cygwin used to be fully supported, but support broke because there was no one around that was maintaining it.  There has been renewed interest, and some progress toward fixing cygwin support (more help is appreciated), but it cannot be called a supported platform at the moment because there is no maintainer on our team and there is no buildbot.  There are hopes that both of these deficiencies will be remedied.

This issue is a duplicate of issue 21085, and there is a patch in that issue that has not been applied yet.
msg277655 - (view) Author: Ron Barak (ronbarak) * Date: 2016-09-28 19:29
Can I apply http://bugs.python.org/file44208/3.5-issue21085-struct_siginfo-2.patch to 3.6 as is?
msg277656 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2016-09-28 19:31
If you can't please report it on that issue.
History
Date User Action Args
2016-09-28 19:31:13r.david.murraysetmessages: + msg277656
2016-09-28 19:29:26ronbaraksetmessages: + msg277655
2016-09-28 19:13:23r.david.murraysetnosy: + r.david.murray
messages: + msg277654
2016-09-28 19:09:06ronbaraksetmessages: + msg277653
2016-09-28 19:04:52r.david.murraysetstatus: open -> closed
superseder: Cygwin does not provide siginfo_t.si_band
resolution: duplicate
stage: resolved
2016-09-28 18:59:08christian.heimessetnosy: + christian.heimes
messages: + msg277651
2016-09-28 18:31:22ronbarakcreate