classification
Title: setuptools failing to read from setup.cfg only in Python 3.6
Type: behavior Stage: resolved
Components: Distutils Versions: Python 3.6
process
Status: closed Resolution: third party
Dependencies: Superseder:
Assigned To: Nosy List: Roy Williams, brett.cannon, dstufft, eric.araujo, jaraco
Priority: normal Keywords:

Created on 2016-09-26 17:05 by Roy Williams, last changed 2017-02-25 20:28 by brett.cannon. This issue is now closed.

Messages (2)
msg277434 - (view) Author: Roy Williams (Roy Williams) * Date: 2016-09-26 17:05
Howdy,

I'm attempting to make a change to the mock package in Python (related to http://bugs.python.org/issue28260), and it appears their CI is broken in Python 3.6 only. The problem appears to originate from setuptools, but this only fails in Python 3.6

Here's the last time the mock jobs passed:
https://travis-ci.org/testing-cabal/mock/jobs/153850304 
Here's where they started failing:
https://travis-ci.org/testing-cabal/mock/jobs/159121114

Here's the core of the issue. AFAICT in Python 3.6 setuptools isn't parsing (or is incorrectly parsing) setup.cfg.  I filed https://github.com/pypa/setuptools/issues/800 with the PyPA folks, but honestly I am unsure if the issue is Python itself or setuptools.

Interestingly, when this build went from "passing" to "failing", both were running Python 3.6.0a4+.  

1.43s$ pip install -U .[docs,test]
Processing /home/travis/build/testing-cabal/mock
  mock 2.0.1.dev2 does not provide the extra 'docs'
  mock 2.0.1.dev2 does not provide the extra 'test'
Installing collected packages: mock
  Found existing installation: mock 2.0.0
    Uninstalling mock-2.0.0:
      Successfully uninstalled mock-2.0.0
  Running setup.py install for mock ... done
Successfully installed mock-2.0.1.dev2
I attempted to force travis to pin to the latest version of setuptools and had the same issue (only in Python 3.6, not 3.5 - https://travis-ci.org/testing-cabal/mock/builds/162838672)
msg288579 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2017-02-25 20:28
Closing as this should be a setuptools issue (if it still is).
History
Date User Action Args
2017-02-25 20:28:35brett.cannonsetstatus: open -> closed

nosy: + brett.cannon
messages: + msg288579

resolution: third party
stage: resolved
2016-10-12 17:53:53berker.peksagsetnosy: + jaraco
2016-09-26 21:00:32Roy Williamssettype: behavior
2016-09-26 17:05:38Roy Williamscreate