classification
Title: bz2.open does not use __fspath__ (PEP 519)
Type: behavior Stage: resolved
Components: Versions: Python 3.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Add PathLike objects support to BZ2File
View: 27511
Assigned To: Nosy List: chrysn, serhiy.storchaka
Priority: normal Keywords:

Created on 2016-09-25 10:33 by chrysn, last changed 2016-09-25 10:40 by serhiy.storchaka. This issue is now closed.

Messages (2)
msg277357 - (view) Author: chrysn (chrysn) * Date: 2016-09-25 10:33
The bz2.open function accepts a file name; after PEP 519 (file system path protocol) it "is expected that most APIs in Python's standard library that currently accept a file system path will be updated appropriately to accept path objects".

BZ2File explicitly checks for types (bz2.py:94-97), so it will need explicit adaption.
msg277360 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2016-09-25 10:40
This is a duplicate of issue27511 and issue28225.
History
Date User Action Args
2016-09-25 10:40:20serhiy.storchakasetstatus: open -> closed

superseder: Add PathLike objects support to BZ2File

nosy: + serhiy.storchaka
messages: + msg277360
resolution: duplicate
stage: resolved
2016-09-25 10:33:05chrysncreate