classification
Title: Exe or MSI unable to find Py3.5
Type: behavior Stage: resolved
Components: Distutils, Windows Versions: Python 3.5
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: dstufft, eric.araujo, jcrmatos, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords: 3.5regression

Created on 2016-09-19 22:34 by jcrmatos, last changed 2021-02-03 18:21 by steve.dower. This issue is now closed.

Messages (3)
msg276988 - (view) Author: (jcrmatos) * Date: 2016-09-19 22:34
Exe or MSI created by
python setup.py bdist_wininst
and
python setup.py bdist_msi
on a Py3.5 are unable to find Py3.5 installed.
The build machine is not the same as the installation machine (destination).
Tried changing Py3.5 installation on the destination from user mode to all users, same result.
msg276992 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2016-09-19 23:25
Looks like we forgot to update PC/bdist_wininst/install.c for the "3.5-32" sys.winver format. Guessing it'll find a 64-bit install just fine.
msg386362 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2021-02-03 18:21
Distutils is now deprecated (see PEP 632) and all tagged issues are being closed. From now until removal, only release blocking issues will be considered for distutils.

If this issue does not relate to distutils, please remove the component and reopen it. If you believe it still requires a fix, most likely the issue should be re-reported at https://github.com/pypa/setuptools
History
Date User Action Args
2021-02-03 18:21:30steve.dowersetstatus: open -> closed
resolution: out of date
messages: + msg386362

stage: test needed -> resolved
2016-09-19 23:25:10steve.dowersetkeywords: + 3.5regression

messages: + msg276992
components: + Windows
stage: test needed
2016-09-19 22:38:56ned.deilysetnosy: + paul.moore, tim.golden, zach.ware, steve.dower
2016-09-19 22:34:46jcrmatoscreate