classification
Title: platform.release() incorrect in Python 3.5.2 on Windows 2008ServerR2
Type: behavior Stage: resolved
Components: Library (Lib), Windows Versions: Python 3.5
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: steve.dower Nosy List: James Domingo, SilentGhost, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords: 3.5regression

Created on 2016-08-30 00:34 by James Domingo, last changed 2016-09-10 01:29 by steve.dower. This issue is now closed.

Messages (3)
msg273890 - (view) Author: James Domingo (James Domingo) Date: 2016-08-30 00:34
The platform.release() function in Python 3.5.1 returns the correct value on Windows 2008 Server R2:

  C:\Users\jdoe\Documents\Python>python-3.5.1-embed-amd64\python.exe
  Python 3.5.1 (v3.5.1:37a07cee5969, Dec  6 2015, 01:54:25) [MSC v.1900 64 bit (AM
  D64)] on win32
  Type "help", "copyright", "credits" or "license" for more information.
  >>> import platform
  >>> platform.release()
  '2008ServerR2'

However, the function in the latest release, Python 3.5.2, misidentifies the system as Windows 7:

  C:\Users\jdoe\Documents\Python>python-3.5.2-embed-amd64\python.exe
  Python 3.5.2 (v3.5.2:4def2a2901a5, Jun 25 2016, 22:18:55) [MSC v.1900 64 bit (AM
  D64)] on win32
  Type "help", "copyright", "credits" or "license" for more information.
  >>> import platform
  >>> platform.release()
  '7'
msg273902 - (view) Author: SilentGhost (SilentGhost) * (Python triager) Date: 2016-08-30 06:38
This seems to be a consequence of issue 26513. Would you mind re-posting your message there.
msg275529 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2016-09-10 01:29
Fixed on issue26513
History
Date User Action Args
2016-09-10 01:29:12steve.dowersetstatus: open -> closed
messages: + msg275529

assignee: steve.dower
resolution: fixed
stage: resolved
2016-08-30 06:38:51SilentGhostsetnosy: + paul.moore, tim.golden, SilentGhost, zach.ware, steve.dower
messages: + msg273902

components: + Windows
keywords: + 3.5regression
2016-08-30 00:34:04James Domingocreate