classification
Title: Add a clear screen button or menu choice for IDLE
Type: enhancement Stage: resolved
Components: IDLE Versions: Python 3.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: IDLE - an extension to clear the shell window
View: 6143
Assigned To: terry.reedy Nosy List: rhettinger, terry.reedy
Priority: normal Keywords: easy

Created on 2016-08-16 04:31 by rhettinger, last changed 2016-08-16 05:19 by terry.reedy. This issue is now closed.

Messages (2)
msg272826 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2016-08-16 04:31
Learners in my classes commonly request this feature.  Beyond just providing a cosmetic clean-up, this would be useful for recovering from IDLE's catastrophic slow-downs after trying to print a very wide line (i.e. the repr of a string containing a full webpage or text file, see http://bugs.python.org/issue1442493 ).
msg272838 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2016-08-16 05:19
This is essentially a duplicate of your #17632, which proposed Clear Screen + Restart, which was closed as a duplicate of #6143, which has some patches.
History
Date User Action Args
2016-08-16 05:19:33terry.reedysetstatus: open -> closed
superseder: IDLE - an extension to clear the shell window
messages: + msg272838

resolution: duplicate
stage: needs patch -> resolved
2016-08-16 04:31:29rhettingercreate