classification
Title: Idle Shell freezes when printing 100000+ char lines.
Type: crash Stage: resolved
Components: IDLE Versions: Python 3.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: IDLE shell window gets very slow when displaying long lines
View: 1442493
Assigned To: terry.reedy Nosy List: chinmay hegde, terry.reedy
Priority: normal Keywords:

Created on 2016-08-12 19:08 by chinmay hegde, last changed 2016-08-16 06:56 by terry.reedy. This issue is now closed.

Files
File name Uploaded Description Edit
idle_crash.zip chinmay hegde, 2016-08-15 08:13 input.txt input used and issue.py python script
Messages (4)
msg272558 - (view) Author: chinmay hegde (chinmay hegde) Date: 2016-08-12 19:08
Idle editor crashes when input size more than 250 lines given.

Steps to reproduce:-
try with below snippet of code

for i in range(250):
    n=input()

Execute the snippet of code. But while giving the input copy all 250 inputs with single paste.
Editor is crashed. On clicking it's giving "Not responding"

System Config:-
OS - Windows 10
Python Version - 3.5.2
IDLE version - 3.5.2
Tk version - 8.6.4
msg272698 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2016-08-14 22:18
Please describe more exactly the pasting.  Also try the same when you run the same code in the standard python interpreter.  Same or different behavior?  Also, what system?  Pasting varies a bit between OSes.  Is '250' needed'?
msg272733 - (view) Author: chinmay hegde (chinmay hegde) Date: 2016-08-15 08:13
Attaching the exact snippet of code that caused idle crash.issue.py file contains the code and input.txt contains input used.

Also tried with python interpreter. In python interpreter issue is not seen. It's displaying the output.

Pasting of input was done by copying the contents from the notepad file to idle. 

Output is 2 dimensional array in the script(variable 'a'). I think due to the size of the output idle is crashing. But issue is not seen in python interpreter. 

System Config:-
Operating system - Windows 10 64 Bit
Python Version - 3.5.2
IDLE version - 3.5.2
Tk version - 8.6.4
msg272841 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2016-08-16 06:56
200 (lines) * 200 (columns) * 3 (or more chars/item) = line with 120000+ chars -- which you try to print 200 times.  This is known to mostly freeze tk Text windows.  This was not a crash for me, as I was able to close Shell and continue.

PS: Please post uncompressed files next time.
History
Date User Action Args
2016-08-16 06:56:13terry.reedysetstatus: open -> closed
title: Idle editor crashes when input size more than 250 lines given -> Idle Shell freezes when printing 100000+ char lines.
superseder: IDLE shell window gets very slow when displaying long lines
messages: + msg272841

resolution: duplicate
stage: resolved
2016-08-15 08:13:07chinmay hegdesetfiles: + idle_crash.zip

messages: + msg272733
2016-08-14 22:18:51terry.reedysetmessages: + msg272698
2016-08-12 19:08:52chinmay hegdecreate