classification
Title: Build failure with Xcode 8 beta on OSX 10.11
Type: compile error Stage: resolved
Components: macOS Versions: Python 3.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Compiler failure on Mac OS X - sys/random.h
View: 29057
Assigned To: ronaldoussoren Nosy List: Maxime Belanger, ned.deily, ronaldoussoren
Priority: low Keywords:

Created on 2016-07-23 10:49 by ronaldoussoren, last changed 2017-01-19 23:20 by Maxime Belanger. This issue is now closed.

Messages (5)
msg271069 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2016-07-23 10:49
I just noticed that building the Xcode 8 beta 2 on OSX 10.11 results in a link failure of the python binary.

Based on a quick glance at the error (before switching back to Xcode 7):

1) macOS 10.12 appears to have a getentropy function that's detected
   by the configure script.
   
2) For some reason the build environment for configure and the actual build
   are different resulting in the link error.

Even with the link failure fixed the build will fail because getentropy isn't present on 10.11 and hence the binary won't work on 10.11.

IMHO it would be worthwhile to at least create a patch that makes it possible to use Xcode 8 for building on OSX 10.11, and better yet deploy on older OSX releases.

Based on the invasiveness of such a patch we could discuss if the patch would be acceptable for merging.
msg271070 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2016-07-23 10:50
P.S. This issue is mostly a reminder for myself, Xcode 8 is still in beta and hence patches to CPython to support it are IMHO still out of scope for merging at this time.
msg285853 - (view) Author: Maxime Belanger (Maxime Belanger) Date: 2017-01-19 22:47
We're hitting this issue with Python 2.7 (which we deploy on Mac OS X 10.6-10.12). We've worked around it by manually patching `pyconfig.h` to un-define `HAVE_GETENTROPY` before `make`ing. Is a patch is in the works to support weak-linking this symbol (and the other new Sierra additions)?
msg285857 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2017-01-19 23:12
Maxime, there have been a couple of attempts to address this problem.  We believe it now finally fixed for all versions of macOS from 10.6 through 10.12 by the changes in Issue29057.  Unfortunately, for 2.7,x the last set of fixes were after the release of 2.7.13 in December so, until 2.7.14 is released, you may need to manually apply changeset 74eb71b91112.  (Closing this issue as a duplicate of Issue29057)
msg285859 - (view) Author: Maxime Belanger (Maxime Belanger) Date: 2017-01-19 23:20
Glad to hear it! Thanks for the quick followup :).
History
Date User Action Args
2017-01-19 23:20:37Maxime Belangersetmessages: + msg285859
2017-01-19 23:12:35ned.deilysetstatus: open -> closed
superseder: Compiler failure on Mac OS X - sys/random.h
messages: + msg285857

resolution: duplicate
stage: needs patch -> resolved
2017-01-19 22:47:23Maxime Belangersetnosy: + Maxime Belanger
messages: + msg285853
2016-07-23 10:50:48ronaldoussorensetmessages: + msg271070
2016-07-23 10:49:43ronaldoussorencreate