classification
Title: arg 2 of PyErr_SetFromErrnoWithFilename should be const
Type: behavior Stage: resolved
Components: Interpreter Core Versions: Python 2.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: loewis Nosy List: brian.curtin, loewis, ukleinek
Priority: normal Keywords:

Created on 2008-05-04 17:42 by ukleinek, last changed 2010-01-13 05:42 by brian.curtin. This issue is now closed.

Files
File name Uploaded Description Edit
make_PyErr_SetFromErrnoWithFilename_filename_const ukleinek, 2008-05-04 17:42 patch
Messages (2)
msg66220 - (view) Author: Uwe Kleine-König (ukleinek) Date: 2008-05-04 17:42
Compiling an extension I get the warning:

	warning: passing argument 2 of ‘PyErr_SetFromErrnoWithFilename’
discards qualifiers from pointer target type

I passed a const char *, which should be OK from looking at the
implementation of PyErr_SetFromErrnoWithFilename.

Attached is a patch.  I don't expect this to break any API or ABI, but
you might know better.
msg97688 - (view) Author: Brian Curtin (brian.curtin) * (Python committer) Date: 2010-01-13 05:42
This is already fixed in trunk and the various 3.x branches.
History
Date User Action Args
2010-01-13 05:42:27brian.curtinsetstatus: open -> closed
priority: normal


nosy: + brian.curtin
messages: + msg97688
resolution: not a bug
stage: resolved
2008-05-12 17:05:04georg.brandlsetassignee: loewis
nosy: + loewis
2008-05-04 17:42:06ukleinekcreate