classification
Title: distutils.config API different between <=3.5.1 and 3.5.2
Type: behavior Stage: resolved
Components: Distutils, Documentation Versions: Python 3.6, Python 3.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: berker.peksag, docs@python, dstufft, eric.araujo, jhunkeler, xiang.zhang
Priority: normal Keywords:

Created on 2016-07-08 04:16 by jhunkeler, last changed 2016-07-08 07:37 by berker.peksag. This issue is now closed.

Messages (5)
msg269970 - (view) Author: Joe (jhunkeler) Date: 2016-07-08 04:16
In Python 3k releases leading up to 3.5.2, distutils.config imported "ConfigParser", but now imports "RawConfigParser" in the latest release.

The documentation indicates "RawConfigParser" is considered legacy and "ConfigParser" should be used in its place. Was this change intentional, and if not, will it be reverted to the previous behavior for the next patch release?

Thanks,
Joe
msg269975 - (view) Author: Xiang Zhang (xiang.zhang) * (Python committer) Date: 2016-07-08 07:07
I think it's intentional. You can see issue20120.
msg269976 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2016-07-08 07:08
Thanks for the report. Yes, the RawConfigParser change was intentional and it was discussed in issue 20120. I'm marking this as a documentation issue.
msg269978 - (view) Author: Xiang Zhang (xiang.zhang) * (Python committer) Date: 2016-07-08 07:22
Berker, what doc needs to be changed? Although RawConfigParser is legacy but that does not mean it's deprecated, right? We can still use it although the doc suggests us use ConfigParser.
msg269979 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2016-07-08 07:37
I was thinking to document issue 20120 in Misc/NEWS. It turns out I was looking at the wrong commit and it was already documented in eae59b6bf133.
History
Date User Action Args
2016-07-08 07:37:59berker.peksagsetstatus: open -> closed
resolution: not a bug
messages: + msg269979

stage: needs patch -> resolved
2016-07-08 07:22:38xiang.zhangsetmessages: + msg269978
2016-07-08 07:08:33berker.peksagsetassignee: docs@python
components: + Documentation
versions: + Python 3.6
nosy: + berker.peksag, docs@python

messages: + msg269976
stage: needs patch
2016-07-08 07:07:07xiang.zhangsetnosy: + xiang.zhang
messages: + msg269975
2016-07-08 04:16:32jhunkelercreate