classification
Title: Crash with compile returning a value with an error set
Type: Stage: resolved
Components: Interpreter Core Versions: Python 3.6, Python 3.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: benjamin.peterson, brett.cannon, ebarry, georg.brandl, ncoghlan, yselivanov
Priority: normal Keywords:

Created on 2016-06-27 00:26 by ebarry, last changed 2016-06-27 01:37 by ebarry. This issue is now closed.

Messages (2)
msg269328 - (view) Author: Emanuel Barry (ebarry) * Date: 2016-06-27 00:26
My trivial patch exposed a bug in the ast/compiler, where compile() would return a value and set an exception. See http://bugs.python.org/issue27364#msg269323 for more information and steps to reproduce. I looked a bit into it, but I don't know enough about it to be of much help.

(This is just a shot in the dark, but maybe compile() doesn't handle warnings-as-errors properly?)
msg269331 - (view) Author: Emanuel Barry (ebarry) * Date: 2016-06-27 01:37
Nevermind, my mistake.
History
Date User Action Args
2016-06-27 01:37:49ebarrysetstatus: open -> closed
type: crash ->
messages: + msg269331

resolution: not a bug
stage: needs patch -> resolved
2016-06-27 00:26:36ebarrycreate