classification
Title: random failure of test_builtin
Type: behavior Stage: resolved
Components: Tests Versions: Python 3.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: readline-related test_builtin failure
View: 13886
Assigned To: Nosy List: berker.peksag, martin.panter, xdegaye
Priority: normal Keywords:

Created on 2016-06-15 09:29 by xdegaye, last changed 2016-06-15 09:39 by berker.peksag. This issue is now closed.

Messages (2)
msg268613 - (view) Author: Xavier de Gaye (xdegaye) * (Python triager) Date: 2016-06-15 09:29
Not sure if this is relevant, I am using:
    readline 6.3
    ncurses 6.0

The test runs fine when run alone, with the 8991930 random seed:

$ ./python -bb -E -Wd -m test -r -w -uall --randseed 8991930
======================================================================                      [3/1338]
FAIL: test_input_tty_non_ascii (test.test_builtin.PtyTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/xavier/src/python/default/Lib/test/test_builtin.py", line 1583, in test_input_tty_non_
ascii
    self.check_input_tty("prompté", b"quux\xe9", "utf-8")
  File "/home/xavier/src/python/default/Lib/test/test_builtin.py", line 1574, in check_input_tty
    self.assertEqual(input_result, expected)
AssertionError: 'quux' != 'quux\udce9'
- quux
+ quux\udce9
?     +


======================================================================
FAIL: test_input_tty_non_ascii_unicode_errors (test.test_builtin.PtyTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/xavier/src/python/default/Lib/test/test_builtin.py", line 1587, in test_input_tty_non_
ascii_unicode_errors
    self.check_input_tty("prompté", b"quux\xe9", "ascii")
  File "/home/xavier/src/python/default/Lib/test/test_builtin.py", line 1574, in check_input_tty
    self.assertEqual(input_result, expected)
AssertionError: 'quux' != 'quux\udce9'
- quux
+ quux\udce9
?     +
msg268614 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2016-06-15 09:39
This is a duplicate of issue 13886.
History
Date User Action Args
2016-06-15 09:39:00berker.peksagsetstatus: open -> closed

superseder: readline-related test_builtin failure

nosy: + berker.peksag
messages: + msg268614
resolution: duplicate
stage: resolved
2016-06-15 09:29:17xdegayecreate