classification
Title: 3.6.0a2 IDLE.app on OS X fails to launch, use command line idle3.6 instead
Type: Stage: resolved
Components: IDLE Versions: Python 3.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: ned.deily Nosy List: ned.deily, python-dev, terry.reedy
Priority: critical Keywords:

Created on 2016-06-14 00:16 by ned.deily, last changed 2016-06-14 01:13 by ned.deily. This issue is now closed.

Messages (2)
msg268487 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2016-06-14 00:16
For 3.6.0a2, when attempting to launch IDLE.app on OS X (for example, by double-clicking the IDLE icon in the "/Applications/Python 3.6" folder), IDLE does not launch.  In the system.log there will be a log message similar to:

(org.python.IDLE.917792[45897]): Service exited with abnormal code: 1

The problem is that the glue code (idlemain.py) used to launch IDLE from within the IDLE app bundle is trying to import macosxSupport which has been renamed as of 3.6.0a2.  However, there is no longer any reason for the app bundle to import this module: this is vestigial code that I should have removed some releases ago when I refactored macosxSupport.  It hasn't hurt up until now.

As a workaround for 3.6.0a2, you can launch IDLE from a terminal command line:

/usr/local/bin/idle3.6

or you *could* carefully msnuslly edit the file /Applications/Python 3.6/IDLE.app/Contents/Resources/idlemain.py to remove the two lines near the end:

from idlelib import macosxSupport
macosxSupport._appbundle = True

Fix for 3.6.0a3 to follow.
msg268488 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2016-06-14 00:28
New changeset 675569bee37f by Ned Deily in branch '2.7':
Issue #27310: remove vestigial import in IDLE.app
https://hg.python.org/cpython/rev/675569bee37f

New changeset 0cf4bda2882c by Ned Deily in branch '3.5':
Issue #27310: remove vestigial import in IDLE.app
https://hg.python.org/cpython/rev/0cf4bda2882c

New changeset 9ba934d159e3 by Ned Deily in branch 'default':
Issue #27310: Fix IDLE.app failure to launch on OS X due to vestigial import.
https://hg.python.org/cpython/rev/9ba934d159e3
History
Date User Action Args
2016-06-14 01:13:03ned.deilysetnosy: + terry.reedy
2016-06-14 00:30:30ned.deilysetstatus: open -> closed
resolution: fixed
stage: needs patch -> resolved
2016-06-14 00:28:37python-devsetnosy: + python-dev
messages: + msg268488
2016-06-14 00:16:34ned.deilycreate