classification
Title: FileFinder.find_spec() incompatible with finder specification
Type: Stage:
Components: Versions: Python 3.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: paulmar
Priority: normal Keywords:

Created on 2016-06-09 04:58 by paulmar, last changed 2016-06-09 05:00 by paulmar. This issue is now closed.

Messages (1)
msg267961 - (view) Author: Paul Marinescu (paulmar) Date: 2016-06-09 04:58
importlib.machinery.FileFinder.find_spec is incompatible with importlib.abc.MetaPathFinder.find_spec (different number of arguments).

The following leads to a runtime error:

loader = (importlib.machinery.SourceFileLoader, importlib.machinery.SOURCE_SUFFIXES)
sys.meta_path.append(importlib.machinery.FileFinder('/', loader))
History
Date User Action Args
2016-06-09 05:00:24paulmarsetstatus: open -> closed
resolution: not a bug
2016-06-09 04:58:21paulmarcreate