classification
Title: IDLE 3.5.1 not using Tk 8.6
Type: Stage: resolved
Components: IDLE, macOS Versions: Python 3.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Old Sub Sailor, kbk, ned.deily, roger.serwy, ronaldoussoren, terry.reedy
Priority: normal Keywords:

Created on 2016-06-04 15:07 by Old Sub Sailor, last changed 2016-06-05 00:25 by Old Sub Sailor. This issue is now closed.

Files
File name Uploaded Description Edit
About IDLE.png Old Sub Sailor, 2016-06-04 15:07
Messages (8)
msg267255 - (view) Author: Glenn Travis (Old Sub Sailor) Date: 2016-06-04 15:07
I do not know if this is truly an issue, but it is a concern to me. 

I installed Tk 8.6 after reading all the Macintosh OS warnings online and in the IDLE window. However, according to the About IDLE box, IDLE is still "using" 8.5; and the warning still appears when I open IDLE. 

I may have missed it, but I did not see any way update IDLE or some Unix file to correct this in the online documentation.
msg267261 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2016-06-04 16:25
Assuming you are using the Python 3.5.1 from the python.org OS X binary installer, you need to install a version of Tcl/Tk 8.5 (such as ActiveTcl 8.5.18), not 8.6, as is described here: https://www.python.org/download/mac/tcltk/.
msg267264 - (view) Author: Glenn Travis (Old Sub Sailor) Date: 2016-06-04 16:30
Ok, 
Thank you. I wonder why they have OS X version 8.6, which seems to be the default dl link page?
> On Jun 4, 2016, at 11:25 AM, Ned Deily <report@bugs.python.org> wrote:
> 
> 
> Ned Deily added the comment:
> 
> Assuming you are using the Python 3.5.1 from the python.org OS X binary installer, you need to install a version of Tcl/Tk 8.5 (such as ActiveTcl 8.5.18), not 8.6, as is described here: https://www.python.org/download/mac/tcltk/.
> 
> ----------
> resolution:  -> not a bug
> stage: test needed -> resolved
> status: open -> closed
> type: behavior -> 
> 
> _______________________________________
> Python tracker <report@bugs.python.org>
> <http://bugs.python.org/issue27217>
> _______________________________________
msg267266 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2016-06-04 16:34
Well, 8.6 is the latest version of Tcl/Tk but, because Apple does not yet ship 8.6 in OS X, we have continued to use 8.5.  That will change in Python 3.6.
msg267267 - (view) Author: Glenn Travis (Old Sub Sailor) Date: 2016-06-04 16:37
Thank you again,
Does that mean that I will need to reinstall 8.6 when python 3.6 comes out?
> On Jun 4, 2016, at 11:34 AM, Ned Deily <report@bugs.python.org> wrote:
> 
> 
> Ned Deily added the comment:
> 
> Well, 8.6 is the latest version of Tcl/Tk but, because Apple does not yet ship 8.6 in OS X, we have continued to use 8.5.  That will change in Python 3.6.
> 
> ----------
> 
> _______________________________________
> Python tracker <report@bugs.python.org>
> <http://bugs.python.org/issue27217>
> _______________________________________
msg267272 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2016-06-04 16:57
Multiple versions of Tcl/Tk can co-exist.  Installing ActiveTcl 8.5.x does not remove the 8.6.x version you installed earlier.
msg267274 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2016-06-04 17:00
Glenn, in the future when you reply by email, please trim off the quoted message you are responding to, as your reply appears beneath it on the web site.
msg267354 - (view) Author: Glenn Travis (Old Sub Sailor) Date: 2016-06-05 00:25
Alas, I apologize
History
Date User Action Args
2016-06-05 00:25:26Old Sub Sailorsetmessages: + msg267354
2016-06-04 17:00:41terry.reedysetmessages: + msg267274
2016-06-04 16:57:06ned.deilysetmessages: + msg267272
2016-06-04 16:37:54Old Sub Sailorsetmessages: + msg267267
2016-06-04 16:34:53ned.deilysetmessages: + msg267266
2016-06-04 16:30:51Old Sub Sailorsetmessages: + msg267264
2016-06-04 16:25:29ned.deilysetstatus: open -> closed
type: behavior ->
messages: + msg267261

resolution: not a bug
stage: test needed -> resolved
2016-06-04 15:22:10abarrysetversions: + Python 3.5
nosy: + roger.serwy, ned.deily, terry.reedy, kbk, ronaldoussoren

components: + IDLE, macOS
type: resource usage -> behavior
stage: test needed
2016-06-04 15:07:25Old Sub Sailorcreate