classification
Title: Wordcode, part 2
Type: enhancement Stage: resolved
Components: Interpreter Core Versions: Python 3.10
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: Demur Rumed, Dennis Sweeney, Mark.Shannon, berker.peksag, db3l, eric.fahlgren, godaygo, pablogsal, python-dev, rhettinger, serhiy.storchaka, vstinner
Priority: release blocker Keywords: patch

Created on 2016-05-26 13:13 by serhiy.storchaka, last changed 2021-04-05 16:25 by pablogsal. This issue is now closed.

Files
File name Uploaded Description Edit
wordcode2.patch serhiy.storchaka, 2016-05-26 13:13 review
word-jump-offsets.patch serhiy.storchaka, 2016-05-28 15:46 review
wordcode-refactor.patch serhiy.storchaka, 2016-06-08 19:42 review
wordcode-refactor2.patch serhiy.storchaka, 2016-06-10 18:54 review
Pull Requests
URL Status Linked Edit
PR 25069 merged Mark.Shannon, 2021-03-29 15:17
PR 25172 merged Dennis Sweeney, 2021-04-04 00:29
Messages (36)
msg266431 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2016-05-26 13:13
This is the second stage of converting to wordcode (issue26647).

Proposed patch makes bytecodecode consisting of code units (16-bit words) instead of bytes. It includes following changes:

* Changes meaning of jump offsets. They counts not bytes, but code units. This extends the range addressed by short commands (from 256 bytes to 256 words) and simplifies ceval.c.

* Changes f_lasti, tb_lasti etc to count code units instead of bytes.

* Changes disassembler to show addresses in code units, not bytes.

* Refactores the code.

These changes break compatibility (already broken by switching to 16-bit bytecode). The first one breaks compatibility with compiled bytecode and needs incrementing the magic number.
msg266435 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2016-05-26 13:29
> Changes f_lasti, tb_lasti etc to count code units instead of bytes.

I asked Demur to not break f_lasti. I don't understand if this change
breaks applications using f_lasti or not.

For example, asyncio/coroutines.py uses:

            if caller.f_code.co_code[caller.f_lasti] != _YIELD_FROM:
                value = value[0]

Does this code still work with your change?

Maybe this code is already broken by wordcode, but it doesn't really
matter since it should only be used on the exact version 3.4.0. The
code works around a bug in Python 3.4.0, fixed in Python 3.4.1 (issue
#21209).

Other known users of f_lasti are development tools like debuggers
(pdb), profilers, code coverage, etc. We should check these tools.
msg266446 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2016-05-26 18:38
So is avoiding changing f_lasti just to minimize breakage of tools? Aren't they going to have to update to support the wordcode changes anyway?
msg266447 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2016-05-26 18:55
The patch contains the change of Lib/asyncio/coroutines.py. This is the only change in Python code besides the dis module.

I can keep f_lasti to be twice the number of instructions, but this will complicate the patch. The simplest way perhaps is to convert this read-only attribute to the property that multiplies internal f_lasti by 2.
msg266489 - (view) Author: Demur Rumed (Demur Rumed) * Date: 2016-05-27 12:06
https://github.com/search?q=f_lasti&type=Code

Popular use of f_lasti is checking it for -1, checking the instruction at the byte offset of f_lasti, checking the argument with code[f_lasti+1] (Some bad code checking f_lasti+3 which'll break with 3.6)

abarnert discussed how bytecode should be typed to Python code. Ideally it'd be typed as a "(instruction, arg)" tuple. He considered creating a "words" type similar to "bytes" but with 16 bit values. It's a bit niche to introduce a builtin for. So if the co_code object is remaining a bytes object then it seems intuitive to keep f_lasti as a bytes offset. Clashes with jump offsets no longer being a bytes offset even in Python code tho

In reality most of the results on github all seem to be copying a few distinct uses. So maybe backwards compatibiltiy isn't so important

Other search https://searchcode.com/?q=f_lasti&loc=0&loc2=10000&src=3&src=7&src=1&lan=19 doesn't produce many results either
msg266490 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2016-05-27 12:29
> if the co_code object is remaining a bytes object then it seems intuitive to keep f_lasti as a bytes offset

Right.

> In reality most of the results on github all seem to be copying a few distinct uses. So maybe backwards compatibiltiy isn't so important

Backwards compatibiltiy is important.
msg266556 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2016-05-28 14:53
Here is a patch that implements only the first change -- makes jump offsets be in 16-bit units, not bytes. This is minimal change, it doesn't include refactoring.
msg266604 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2016-05-29 17:33
I don't see how this is a simplification.   The additional /2 and *2 on the affected lines makes the code a little harder to reason about and it loses some of the cleanness achieved by the last patch.   To me, it also increases conceptual complexity because INSTR_OFFSET() no longer gives the byte address adjustment.
msg266611 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2016-05-29 18:40
word-jump-offsets.patch doesn't simplify the code, but rather complicates it, because this is minimal patch that doesn't include the refactoring. The main benefit of this patch is that it extends the range addressed by short jump instruction. The other benefit is that the target of jump instruction is now always point at instruction boundary.

wordcode2.patch includes refactoring and other changes:

* Changes jump offsets. This extends addressed range and can make co_code more compact.
* Changes co_lnotab. This can make co_lnotab more compact.
* Changes f_lasti.
* Changes the disassembler.
* Refactors the C code (makes it codeunit-oriented instead of byte-oriented). Simplifies the code complicated by other changes.

I can provide these steps by separate patches (word-jump-offsets.patch is the first of them), but every separate patch can temporary complicate the code. Three of these changes (except the disassembler changing and refactoring) break the compatibility of pyc-files and need incrementing the magic number.
msg267880 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2016-06-08 19:42
Here is a patch that just refactors the code. It renames OPCODE and OPCODE to _Py_OPCODE and _Py_OPCODE and moves them to code.h for reusing in other files. Introduces _Py_CODEUNIT as an alias to unsigned short (if it is 16-bit, otherwise a compile error is raised). Makes compiler and peepholer to operate with _Py_CODEUNIT units instead of bytes. Replaces or scale magic numbers with sizeof(_Py_CODEUNIT). Adds fill_nops() for filling specified region with NOPs. Decreases memory consumption for peepholer (doesn't allocate memory for unused odd addresses).
msg268132 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2016-06-10 17:43
I really don't think any of this should be done at all.  The current code is clean and fast (and to my eyes at least is very readable).
msg268142 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2016-06-10 18:49
This is not just about cleaning (to my eyes current code is not very readable, and I read it many times, perhaps more times than any other core developer in last months). There are other benefits. Changing jump offsets allows to get rid of EXTENDED_ARGs for the part of jump opcodes. Changing lnotab makes it more compact and allows the peepholer to optimize the code that it rejects now. Refactoring includes the change that decreases memory consumption of the peepholer (from 4 bytes per bytecode byte to 2 bytes per bytecode byte). Changing jump offsets together with changing f_lasti removes redundant multiplications and divisions by 2. Separate changes can complicate some parts of code, but next changes removes this complication. Only all changes together achieve maximal cleanness.

I think that converting to wordcode is not complete without these changes. I approved the wordcode patch only having in mind following changes. It is more painless to make all changes in one Python release than break compatibility during few releases.
msg268143 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2016-06-10 18:54
update patch replaces yet few magic constants.
msg268145 - (view) Author: Demur Rumed (Demur Rumed) * Date: 2016-06-10 19:06
The patches LGTM & seem to be implementation of follow up ideas outlined in the first portion. It'd be good to verify that benchmarks are relatively unaffected
msg275771 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2016-09-11 10:48
New changeset dd046963bd42 by Serhiy Storchaka in branch 'default':
Issue #27129: Replaced wordcode related magic constants with macros.
https://hg.python.org/cpython/rev/dd046963bd42
msg275773 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2016-09-11 11:49
From http://buildbot.python.org/all/builders/s390x%20Debian%203.x/builds/1811/steps/compile/logs/stdio (I also saw the same compile error on another Linux boxes)

_freeze_importlib: Python/peephole.c:524: PyCode_Optimize: Assertion `((codestr[i]) >> 8) == 100' failed.
Makefile:735: recipe for target 'Python/importlib.h' failed
make: *** [Python/importlib.h] Aborted
msg275780 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2016-09-11 12:19
New changeset b49a938eaa31 by Serhiy Storchaka in branch 'default':
Fixed refactoring bug in dd046963bd42 (issue27129).
https://hg.python.org/cpython/rev/b49a938eaa31
msg275781 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2016-09-11 12:20
Thanks Berker!
msg276044 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2016-09-12 13:44
This issue can now be closed, no?
msg276049 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2016-09-12 14:00
No, only the simpler and safer part was committed. I divided the original patch on four parts, but since the code was significantly evolved, they no longer applied clearly.
msg276055 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2016-09-12 14:55
Serhiy Storchaka added the comment:
> No, only the simpler and safer part was committed. I divided the original patch on four parts, but since the code was significantly evolved, they no longer applied clearly.

Oh ok. I saw that a change was pushed, I didn't read the history of the issue.

I should take a look after the beta1 release.
msg315266 - (view) Author: Kirill Balunov (godaygo) Date: 2018-04-13 21:08
Hello, what is the future of this patch? Such a feeling that the transition to wordcode is still in some half-way state.
msg389707 - (view) Author: Mark Shannon (Mark.Shannon) * (Python committer) Date: 2021-03-29 15:03
frame.f_lasti and traceback.tb_lasti are best left as byte offsets.
There is no guarantee that we won't go back to variable length instructions.
For example, a "LONG_JUMP" instruction which is 4 bytes long and takes a 3 byte offset might well be a worthwhile extension.

However, changing bytecode offsets and the internal representation of frame.f_lasti will reduce the number of "EXTENDED_ARG"s by 60% or more and makes interpreter dispatch a tad more efficient.
msg389991 - (view) Author: Mark Shannon (Mark.Shannon) * (Python committer) Date: 2021-04-01 15:00
New changeset fcb55c0037baab6f98f91ee38ce84b6f874f034a by Mark Shannon in branch 'master':
bpo-27129: Use instruction offsets, not byte offsets, in bytecode and internally. (GH-25069)
https://github.com/python/cpython/commit/fcb55c0037baab6f98f91ee38ce84b6f874f034a
msg390017 - (view) Author: David Bolen (db3l) * Date: 2021-04-01 23:17
Note that this commit appears to be causing exceptions for the Win10 buildbot, failing the PyCode_Addr2Line assertion in codeobject.c line 1252.

The assertion seems to pop up at differing points during each test run, but the builder has yet to complete a full test run successfully.
msg390024 - (view) Author: Mark Shannon (Mark.Shannon) * (Python committer) Date: 2021-04-02 00:18
That assertion is correct, and hasn't changed.

Do you have a traceback?
The buildbot just shows the assertion message with no context.
msg390025 - (view) Author: David Bolen (db3l) * Date: 2021-04-02 00:58
Unfortunately, not at the moment - what's in the buildbot log is what's available.  The RTL assertion aborts the process.

The tests involved (such as test_clinic) do seem reproducible in a few separate tries, though again, all they do is terminate.

As the assertion should be correct, I'm guessing it's reflecting an earlier corruption.  There's some other oddities, such as the "Leaf" related failures in test_peg_generator that showed up at the same time, in case that offers any hint.  Since Leaf and StringLeaf are almost next to each other in grammar.py I can't see how it can be undefined.

The worker only has the core build tools version of VS so can't directly debug this further locally.  I can look into using a different machine to try to get some details, but I'm not sure as to timing.
msg390082 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2021-04-02 16:42
I get two crashes on Windows with Python built in debug mode:

* I got a crash. I wasn't sure if it was an issue of incremental build, so I rebuilt Python.
* On a fresh build, Python crashed on the CALL_FUNCTION_KW opcode, when loading names, names was equal to 0xFFFFFFFFFFFFFFFF:

            names = POP();
            assert(PyTuple_Check(names)); <=== HERE

  Moreover, f->f_code was equal to 0xCBCBCBCBCBCBCBCB. But it was really weird. I added assertion to ensure that f->f_code was not equal 0xCBCBCBCBCBCBCBCB: the assertion didn't fail.

* I ran "git clean -fdx" and built again Python. This time, it went fine, moreover the whole test suite passed cleanly!? "== Tests result: SUCCESS ==" and "386 tests OK."

I build Python with:

   PCbuild\build.bat -d -p x64 -e
msg390085 - (view) Author: David Bolen (db3l) * Date: 2021-04-02 18:13
Ah, Victor, that helps.  I was having trouble reproducing the problem on a different system.  I was suspecting a small difference in compiler version, but I hadn't considered it being because I started fresh.

From what I can see, a particular build tree can be successful if it remains on either side of the instruction commit, but you can't cross the boundary - in either direction.  There's clearly some build artifact not being reset properly that gets out of sync.  I've been able to create odd name errors even in older commits as long as the first one I build is at or after the instruction commit.

But a pristine checkout on the buildbot of the latest master works, as does a git clean on the tree. 

I always use the buildbot scripts for building and they invoke a full clean first.  So either the clean process on Windows is missing something, or there's an artifact that is supposed to be kept in sync in the source tree itself that isn't.  I'm not familiar enough with the internals to guess at which yet.  I suppose given that it's not a problem on other buildbots argues for the clean issue, although I suppose it could also be something that is only kept in the tree to benefit a subset of systems, like Windows.

(While resetting the checkouts on the buildbot should therefore fix the current exceptions, I'm going to leave that alone for the moment, since that leaves it positioned to confirm any subsequent fix)
msg390088 - (view) Author: David Bolen (db3l) * Date: 2021-04-02 18:53
I'm out of time for a bit, but it appears that the root issue is old pyc files in Tools/clinic/__pycache__ that aren't removed during a clean process, and appear to be the source of all of the errors.  Manually pruning that folder fixes things.

I believe the regular (non-Windows) makefile automatically prunes all __pycache__ folders in the tree during clean which is probably why that's not an issue on other systems.
msg390099 - (view) Author: David Bolen (db3l) * Date: 2021-04-02 20:59
I've opened issue #43709 for fixing the buildbot clean script under Windows.  It needs to clean the Tools and Parser trees, not just Lib (and there are a few other folders involved besides clinic)
msg390151 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2021-04-03 23:15
> New changeset fcb55c0037baab6f98f91ee38ce84b6f874f034a by Mark Shannon in branch 'master':
> bpo-27129: Use instruction offsets, not byte offsets, in bytecode and internally. (GH-25069)

This change broke buildbots, please revert it to repair buildbots.

More and more people are affected: https://bugs.python.org/issue43719
msg390152 - (view) Author: David Bolen (db3l) * Date: 2021-04-03 23:24
I don't think reverting the commit at this point would necessarily be helpful.  While it might fix some systems, it could newly break anyone who happened to do their first build since the commit was in place.

I didn't want to bug anyone over the weekend, but I've got a PR as part of issue #43709 that I believe would fix this going forward, if anyone with access might have an opportunity to review it.
msg390157 - (view) Author: Dennis Sweeney (Dennis Sweeney) * (Python triager) Date: 2021-04-03 23:58
I notice this in _bootstrap_external.py: the magic number did not get changed, only the comment:


#     Python 3.10a2 3433 (RERAISE restores f_lasti if oparg != 0)
#     Python 3.10a6 3434 (PEP 634: Structural Pattern Matching)
#     Python 3.10a7 3435 Use instruction offsets (as opposed to byte offsets).

#
# MAGIC must change whenever the bytecode emitted by the compiler may no
# longer be understood by older implementations of the eval loop (usually
# due to the addition of new opcodes).
#
# Whenever MAGIC_NUMBER is changed, the ranges in the magic_values array
# in PC/launcher.c must also be updated.
MAGIC_NUMBER = (3434).to_bytes(2, 'little') + b'\r\n'
_RAW_MAGIC_NUMBER = int.from_bytes(MAGIC_NUMBER, 'little')  # For import.c
msg390178 - (view) Author: Mark Shannon (Mark.Shannon) * (Python committer) Date: 2021-04-04 08:33
New changeset c368ce74d2c9bcbf1ec320466819c2d4768252f7 by Dennis Sweeney in branch 'master':
bpo-27129: Update magic numbers and bootstrapping for GH-25069 (GH-25172)
https://github.com/python/cpython/commit/c368ce74d2c9bcbf1ec320466819c2d4768252f7
msg390242 - (view) Author: Pablo Galindo Salgado (pablogsal) * (Python committer) Date: 2021-04-05 16:25
Closing as this is fixed. Feel free to reopen if there is something missing
History
Date User Action Args
2021-04-05 16:25:09pablogsalsetstatus: open -> closed

nosy: + pablogsal
messages: + msg390242

resolution: fixed
stage: patch review -> resolved
2021-04-04 08:33:31Mark.Shannonsetmessages: + msg390178
2021-04-04 02:34:59ned.deilysetpriority: normal -> release blocker
versions: + Python 3.10, - Python 3.6
2021-04-04 00:29:35Dennis Sweeneysetpull_requests: + pull_request23913
2021-04-03 23:58:02Dennis Sweeneysetnosy: + Dennis Sweeney
messages: + msg390157
2021-04-03 23:24:12db3lsetmessages: + msg390152
2021-04-03 23:15:31vstinnersetmessages: + msg390151
2021-04-02 20:59:25db3lsetmessages: + msg390099
2021-04-02 18:53:37db3lsetmessages: + msg390088
2021-04-02 18:13:52db3lsetmessages: + msg390085
2021-04-02 16:42:31vstinnersetmessages: + msg390082
2021-04-02 00:58:17db3lsetmessages: + msg390025
2021-04-02 00:18:12Mark.Shannonsetmessages: + msg390024
2021-04-01 23:17:45db3lsetnosy: + db3l
messages: + msg390017
2021-04-01 15:00:41Mark.Shannonsetmessages: + msg389991
2021-03-29 15:17:29Mark.Shannonsetpull_requests: + pull_request23819
2021-03-29 15:03:37Mark.Shannonsetmessages: + msg389707
2020-11-06 19:37:26brett.cannonsetnosy: - brett.cannon
2018-04-13 21:08:16godaygosetnosy: + godaygo
messages: + msg315266
2016-11-24 22:20:31vstinnerunlinkissue26647 dependencies
2016-09-12 14:55:45vstinnersetmessages: + msg276055
2016-09-12 14:00:22serhiy.storchakasetmessages: + msg276049
2016-09-12 13:44:00vstinnersetmessages: + msg276044
2016-09-11 12:20:42serhiy.storchakasetmessages: + msg275781
2016-09-11 12:19:39python-devsetmessages: + msg275780
2016-09-11 11:49:30berker.peksagsetnosy: + berker.peksag
messages: + msg275773
2016-09-11 10:48:51python-devsetnosy: + python-dev
messages: + msg275771
2016-06-10 19:06:44Demur Rumedsetmessages: + msg268145
2016-06-10 18:54:37serhiy.storchakasetfiles: + wordcode-refactor2.patch

messages: + msg268143
2016-06-10 18:49:32serhiy.storchakasetmessages: + msg268142
2016-06-10 17:43:39rhettingersetmessages: + msg268132
2016-06-08 19:42:24serhiy.storchakasetfiles: + wordcode-refactor.patch

messages: + msg267880
2016-06-04 21:05:25serhiy.storchakasetnosy: + Mark.Shannon
2016-06-04 17:55:43eric.fahlgrensetnosy: + eric.fahlgren
2016-05-29 18:40:47serhiy.storchakasetmessages: + msg266611
2016-05-29 18:25:53abarrysetmessages: - msg266607
2016-05-29 18:25:41abarrysetmessages: - msg266608
2016-05-29 18:24:18Demur Rumedsetfiles: - forbegin.patch
2016-05-29 18:24:07Demur Rumedsetmessages: + msg266608
2016-05-29 18:23:14Demur Rumedsetfiles: + forbegin.patch

messages: + msg266607
2016-05-29 17:33:51rhettingersetnosy: + rhettinger
messages: + msg266604
2016-05-28 15:46:10serhiy.storchakasetfiles: + word-jump-offsets.patch
2016-05-28 15:45:53serhiy.storchakasetfiles: - word-jump-offsets.patch
2016-05-28 14:53:26serhiy.storchakasetfiles: + word-jump-offsets.patch

messages: + msg266556
2016-05-27 12:29:50vstinnersetmessages: + msg266490
2016-05-27 12:06:00Demur Rumedsetnosy: + Demur Rumed
messages: + msg266489
2016-05-26 18:55:33serhiy.storchakasetmessages: + msg266447
2016-05-26 18:38:31brett.cannonsetmessages: + msg266446
2016-05-26 18:07:14brett.cannonsetnosy: + brett.cannon
2016-05-26 13:29:29vstinnersetmessages: + msg266435
2016-05-26 13:14:27serhiy.storchakalinkissue26647 dependencies
2016-05-26 13:13:07serhiy.storchakacreate