classification
Title: Python2.7.11+ as in Debian testing and Ubuntu 16.04 LTS crashes with segfault
Type: crash Stage:
Components: Versions: Python 2.7
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: Ján Jockusch, doko, ned.deily
Priority: normal Keywords:

Created on 2016-05-18 06:38 by Ján Jockusch, last changed 2016-06-05 20:56 by doko. This issue is now closed.

Files
File name Uploaded Description Edit
testing_script Ján Jockusch, 2016-05-18 06:38 Script to reproduce the segmentation fault
Messages (5)
msg265814 - (view) Author: Ján Jockusch (Ján Jockusch) Date: 2016-05-18 06:38
Python2.7.11+ as distributed by Ubuntu 16.04LTS and Debian testing crashes with a segmentation fault when running a simple Zope2 instance.

Python.org's Python2.7.11 does not exhibit the same crash.

It is possible that one of the patches in debian/patches or another factor of the Debianization introduces a regression or a new issue.

The issue has been registered with Ubuntu here:

https://bugs.launchpad.net/ubuntu/+source/python2.7/+bug/1580577

Matthias Klose, Debian maintainer for the package, has asked me to
report this problem upstream, because otherwise we will invariably run
into this regression in 2.7.12.

I have attached the script I use to produce the segmentation fault. I involves installing Zope2 from the internet, but other that that, it only requires a standard Python2.7 installation (with zlib support).

I have also succeeded in calling and producing this error in gdb, but I don't know how to move on from there.

Any hints on how I can locate the problem are very welcome!
msg265834 - (view) Author: Matthias Klose (doko) * (Python committer) Date: 2016-05-18 19:51
2.7.11+ translates to 20160330 from the 2.7 branch.
msg267469 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2016-06-05 19:56
FWIW, I am also unable to reproduce the crash on OS X with a current top-of-2.7 debug build.  Since it doesn't seem to be able to be reproduced with stock Python 2.7's, perhaps it is time to close the issue here?
msg267474 - (view) Author: Matthias Klose (doko) * (Python committer) Date: 2016-06-05 20:55
I'm unable to reproduce this with the 2.7 branch 20160603.
msg267475 - (view) Author: Matthias Klose (doko) * (Python committer) Date: 2016-06-05 20:56
(checked with the recent packages in Debian unstable and Ubuntu yakkety)
History
Date User Action Args
2016-06-05 20:56:52dokosetmessages: + msg267475
2016-06-05 20:56:18dokosetstatus: open -> closed
resolution: works for me
2016-06-05 20:55:29dokosetmessages: + msg267474
2016-06-05 19:56:08ned.deilysetnosy: + ned.deily
messages: + msg267469
2016-05-18 19:51:22dokosetmessages: + msg265834
2016-05-18 13:02:24zach.waresetnosy: + doko
2016-05-18 06:38:21Ján Jockuschcreate