classification
Title: compile() expected string without null bytes
Type: behavior Stage: resolved
Components: IO Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: serhiy.storchaka, 周伟阳
Priority: normal Keywords:

Created on 2016-05-05 08:19 by 周伟阳, last changed 2016-05-05 08:40 by serhiy.storchaka. This issue is now closed.

Messages (2)
msg264894 - (view) Author: 周伟阳 (周伟阳) Date: 2016-05-05 08:19
"compile() expected string without null bytes"
I met this in python2.7.11, and python2.7.10 is fine.
ENV: DOCKER:2.7.11-alpine, pecan, ceph/pulpito
msg264897 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2016-05-05 08:40
compile() always required a string without null bytes. If it accepted a string with null bytes in 2.7.10 (I don't see the confirmation on this in the source code), it was a bug and is fixed.
History
Date User Action Args
2016-05-05 08:40:41serhiy.storchakasetstatus: open -> closed

nosy: + serhiy.storchaka
messages: + msg264897

resolution: not a bug
stage: resolved
2016-05-05 08:19:50周伟阳create