classification
Title: android: test_posixpath fails
Type: behavior Stage: resolved
Components: Cross-Build, Library (Lib) Versions: Python 3.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: FAIL: test_expanduser when $HOME=/
View: 24950
Assigned To: Nosy List: Alex.Willmer, larry, serhiy.storchaka, xdegaye
Priority: normal Keywords:

Created on 2016-05-03 14:50 by xdegaye, last changed 2016-05-03 17:52 by xdegaye. This issue is now closed.

Messages (5)
msg264734 - (view) Author: Xavier de Gaye (xdegaye) * (Python committer) Date: 2016-05-03 14:50
test_posixpath fails on an android emulator running an x86 system image at API level 21.

On android we have:
root@generic_x86:/data/local/tmp # python
Python 3.6.0a0 (default:f4c6dab59cd8+, May  3 2016, 10:42:45) 
[GCC 4.9 20140827 (prerelease)] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import posixpath, pwd, os
>>> posixpath.expanduser("~")
'/data'
>>> pwd.getpwuid(os.getuid()).pw_dir
'/'
>>>


Test results:

======================================================================
FAIL: test_expanduser (test.test_posixpath.PosixPathTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/sdcard/org.bitbucket.pyona/lib/python3.6/test/test_posixpath.py", line 247, in test_expanduser
    self.assertEqual(posixpath.expanduser("~"), home.rstrip("/"))
AssertionError: '/' != ''
- /
+ 


----------------------------------------------------------------------
Ran 54 tests in 0.046s

FAILED (failures=1)
test test_posixpath failed
1 test failed:
    test_posixpath
Total duration: 0:00:01
msg264739 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2016-05-03 15:26
This is a duplicate of issue24950.
msg264748 - (view) Author: Xavier de Gaye (xdegaye) * (Python committer) Date: 2016-05-03 16:10
That was fast!
Thanks Serhiy.
msg264749 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2016-05-03 17:30
I'll push a patch for issue24950 in short time.

Try to search precedences for other your issues. May be they have patches, additional information or experienced people.
msg264750 - (view) Author: Xavier de Gaye (xdegaye) * (Python committer) Date: 2016-05-03 17:52
You are right. I will do that.
History
Date User Action Args
2016-05-21 07:06:39xdegayelinkissue26865 dependencies
2016-05-03 17:52:43xdegayesetmessages: + msg264750
2016-05-03 17:30:39serhiy.storchakasetmessages: + msg264749
2016-05-03 16:10:45xdegayesetmessages: + msg264748
2016-05-03 15:26:15serhiy.storchakasetstatus: open -> closed

superseder: FAIL: test_expanduser when $HOME=/

nosy: + serhiy.storchaka
messages: + msg264739
resolution: duplicate
stage: resolved
2016-05-03 14:50:47xdegayecreate