classification
Title: ValueError exception raised when using IntEnum with an attribute called "name" and @unique decorator
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.6, Python 3.5
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: ethan.furman Nosy List: Julien Enche, barry, berker.peksag, eli.bendersky, ethan.furman, python-dev, xiang.zhang
Priority: normal Keywords: 3.5regression

Created on 2016-04-30 12:35 by Julien Enche, last changed 2016-05-04 20:27 by berker.peksag. This issue is now closed.

Files
File name Uploaded Description Edit
enumtest.py Julien Enche, 2016-04-30 12:35
Messages (4)
msg264554 - (view) Author: Julien Enche (Julien Enche) Date: 2016-04-30 12:35
The linked file fails with the following error :
ValueError: duplicate values found in <enum 'User'>: id -> User.name, name -> User.name

This exception was not raised with Python 3.4.
msg264555 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2016-04-30 13:33
Looks like 2545bfe0d273 (issue 23486) is the culprit.
msg264568 - (view) Author: Ethan Furman (ethan.furman) * (Python committer) Date: 2016-04-30 17:42
Thanks for catching that.
msg264600 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2016-05-01 17:04
New changeset 1b6581bae5a1 by Ethan Furman in branch '3.5':
issue26893: use mro() to examine class heirarchy
https://hg.python.org/cpython/rev/1b6581bae5a1

New changeset 7188de6b50ab by Ethan Furman in branch 'default':
issue26893: use mro() to examine class heirarchy
https://hg.python.org/cpython/rev/7188de6b50ab
History
Date User Action Args
2016-05-04 20:27:04berker.peksagsetstatus: open -> closed
resolution: fixed
stage: needs patch -> resolved
2016-05-02 09:28:39rhettingersetassignee: ethan.furman
2016-05-01 17:05:00python-devsetnosy: + python-dev
messages: + msg264600
2016-04-30 17:42:50ethan.furmansetmessages: + msg264568
2016-04-30 16:08:16xiang.zhangsetnosy: + xiang.zhang
2016-04-30 13:33:25berker.peksagsetversions: + Python 3.6
nosy: + berker.peksag

messages: + msg264555

keywords: + 3.5regression
stage: needs patch
2016-04-30 13:20:42serhiy.storchakasetnosy: + barry, eli.bendersky, ethan.furman
components: + Library (Lib)
2016-04-30 12:35:26Julien Enchecreate