classification
Title: Hidden test in test_heapq
Type: behavior Stage: resolved
Components: Tests Versions: Python 3.6, Python 3.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: duplicate test name in Lib/test/test_heapq.py
View: 19119
Assigned To: rhettinger Nosy List: berker.peksag, rhettinger, serhiy.storchaka
Priority: normal Keywords:

Created on 2016-04-24 19:20 by serhiy.storchaka, last changed 2016-04-24 20:31 by berker.peksag. This issue is now closed.

Messages (2)
msg264123 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2016-04-24 19:20
There are two methods test_get_only in TestErrorHandling in test_heapq. The latter hides the former.

There is only one test_get_only in 2.7.
msg264129 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2016-04-24 20:31
This is a duplicate of issue 19119.
History
Date User Action Args
2016-04-24 20:31:24berker.peksagsetstatus: open -> closed

superseder: duplicate test name in Lib/test/test_heapq.py

nosy: + berker.peksag
messages: + msg264129
resolution: duplicate
stage: needs patch -> resolved
2016-04-24 19:20:08serhiy.storchakacreate