classification
Title: Incomplete Internationalization in Argparse Module
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.11, Python 3.10, Python 3.9
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Allow translating argparse error messages
View: 39464
Assigned To: Nosy List: IronGrid, berker.peksag, iritkatriel
Priority: normal Keywords: easy, patch

Created on 2016-04-09 22:53 by IronGrid, last changed 2021-12-14 16:22 by iritkatriel. This issue is now closed.

Files
File name Uploaded Description Edit
argparse_i18n.patch IronGrid, 2016-04-09 22:53 Tiny patch for argparse.py review
Messages (2)
msg263116 - (view) Author: Grady Martin (IronGrid) Date: 2016-04-09 22:53
The attached, teensy-weensy patch passes to gettext() a string which had previously been passed as-is.  Relevant mailing list message:

http://article.gmane.org/gmane.comp.python.devel/157035
msg408544 - (view) Author: Irit Katriel (iritkatriel) * (Python committer) Date: 2021-12-14 16:22
Closing as duplicate of issue39464, which has a GitHub PR.
History
Date User Action Args
2021-12-14 16:22:44iritkatrielsetstatus: open -> closed

superseder: Allow translating argparse error messages

nosy: + iritkatriel
messages: + msg408544
resolution: duplicate
stage: patch review -> resolved
2021-12-14 15:42:54iritkatrielsetkeywords: + easy
versions: + Python 3.9, Python 3.10, Python 3.11, - Python 3.6
2016-04-10 06:26:00SilentGhostsetnosy: + berker.peksag

components: + Library (Lib)
stage: patch review
2016-04-09 22:53:33IronGridcreate